summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 07:50:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 07:50:29 +0000
commit607b673266aaa5adb6e54cbebd50bfad237ba3a6 (patch)
tree1f4b2c530a1ac7a1cec4490eb8946dcb432101bb /Makefile.in
parentReleasing debian version 0.7.1-13. (diff)
downloadck-607b673266aaa5adb6e54cbebd50bfad237ba3a6.tar.xz
ck-607b673266aaa5adb6e54cbebd50bfad237ba3a6.zip
Merging upstream version 0.7.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 6f17a12..86b62fe 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -13,7 +13,7 @@ LDNAME=@LDNAME@
LDNAME_VERSION=@LDNAME_VERSION@
LDNAME_MAJOR=@LDNAME_MAJOR@
-all: doc
+all: @EXTRA_BUILD@
$(MAKE) -C src all || exit
@echo
@echo
@@ -34,15 +34,15 @@ check: regressions
install-headers:
mkdir -p $(DESTDIR)/$(HEADERS) || exit
- cp $(SRC_DIR)/include/*.h $(DESTDIR)/$(HEADERS) || exit
+ cp -p $(SRC_DIR)/include/*.h $(DESTDIR)/$(HEADERS) || exit
chmod 644 $(DESTDIR)/$(HEADERS)/ck_*.h || exit
mkdir -p $(DESTDIR)/$(HEADERS)/gcc || exit
cp -r $(SRC_DIR)/include/gcc/* $(DESTDIR)/$(HEADERS)/gcc || exit
- cp include/ck_md.h $(DESTDIR)/$(HEADERS)/ck_md.h || exit
+ cp -p include/ck_md.h $(DESTDIR)/$(HEADERS)/ck_md.h || exit
chmod 755 $(DESTDIR)/$(HEADERS)/gcc
chmod 644 $(DESTDIR)/$(HEADERS)/gcc/ck_*.h $(DESTDIR)/$(HEADERS)/gcc/*/ck_*.h || exit
mkdir -p $(DESTDIR)/$(HEADERS)/spinlock || exit
- cp -r $(SRC_DIR)/include/spinlock/* $(DESTDIR)/$(HEADERS)/spinlock || exit
+ cp -pr $(SRC_DIR)/include/spinlock/* $(DESTDIR)/$(HEADERS)/spinlock || exit
chmod 755 $(DESTDIR)/$(HEADERS)/spinlock
chmod 644 $(DESTDIR)/$(HEADERS)/spinlock/*.h || exit
@@ -51,7 +51,7 @@ install-so:
cp src/libck.so $(DESTDIR)/$(LIBRARY)/$(LDNAME_VERSION)
ln -sf $(LDNAME_VERSION) $(DESTDIR)/$(LIBRARY)/$(LDNAME)
ln -sf $(LDNAME_VERSION) $(DESTDIR)/$(LIBRARY)/$(LDNAME_MAJOR)
- chmod 744 $(DESTDIR)/$(LIBRARY)/$(LDNAME_VERSION) \
+ chmod 755 $(DESTDIR)/$(LIBRARY)/$(LDNAME_VERSION) \
$(DESTDIR)/$(LIBRARY)/$(LDNAME) \
$(DESTDIR)/$(LIBRARY)/$(LDNAME_MAJOR)
@@ -65,7 +65,7 @@ install: all install-headers @INSTALL_LIBS@
mkdir -p $(DESTDIR)/$(LIBRARY) || exit
mkdir -p $(DESTDIR)/$(PKGCONFIG_DATA) || exit
chmod 755 $(DESTDIR)/$(PKGCONFIG_DATA)
- cp build/ck.pc $(DESTDIR)/$(PKGCONFIG_DATA)/ck.pc || exit
+ cp -p build/ck.pc $(DESTDIR)/$(PKGCONFIG_DATA)/ck.pc || exit
@echo
@echo
@echo ---[ Concurrency Kit has installed successfully.