summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-23 11:24:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-23 11:26:20 +0000
commit532394d3e6ff6730030d864399f9d8466a3b91cb (patch)
treeb7640065d3ad5762315fddf25bddff72d33e10e0 /debian/rules
parentAdding upstream version 0.6.0. (diff)
downloadck-532394d3e6ff6730030d864399f9d8466a3b91cb.tar.xz
ck-532394d3e6ff6730030d864399f9d8466a3b91cb.zip
Adding debian version 0.6.0-2.debian/0.6.0-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..468baa9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+
+PLATFORM :=
+$(call lazy,DEB_HOST_ARCH,$$(shell dpkg-architecture -qDEB_HOST_ARCH))
+ifneq (,$(findstring armhf,$(DEB_HOST_ARCH)))
+ PLATFORM += --platform=armv7l
+endif
+
+override_dh_auto_configure:
+ ./configure \
+ --includedir=/usr/include \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --cores=2 \
+ --disable-sse \
+ $(PLATFORM)
+
+override_dh_auto_test:
+ make -j1 check
+
+%:
+ dh $@
+
+# The build target must not be empty. Sadly because of how make
+# works, we have do duplicate the target in this case.
+build:
+ dh $@
+
+.PHONY: build
+