summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 07:50:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 07:50:29 +0000
commit607b673266aaa5adb6e54cbebd50bfad237ba3a6 (patch)
tree1f4b2c530a1ac7a1cec4490eb8946dcb432101bb /doc
parentReleasing debian version 0.7.1-13. (diff)
downloadck-607b673266aaa5adb6e54cbebd50bfad237ba3a6.tar.xz
ck-607b673266aaa5adb6e54cbebd50bfad237ba3a6.zip
Merging upstream version 0.7.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile.in2
-rw-r--r--doc/ck_epoch_barrier2
-rw-r--r--doc/ck_epoch_call2
-rw-r--r--doc/ck_epoch_init2
-rw-r--r--doc/ck_epoch_recycle2
-rw-r--r--doc/ck_epoch_synchronize2
-rw-r--r--doc/ck_hs_init2
-rw-r--r--doc/ck_ht_init4
-rw-r--r--doc/ck_pr_fence_atomic_store2
-rw-r--r--doc/ck_queue6
-rw-r--r--doc/ck_rhs_init2
11 files changed, 17 insertions, 11 deletions
diff --git a/doc/Makefile.in b/doc/Makefile.in
index cbad704..73c0c75 100644
--- a/doc/Makefile.in
+++ b/doc/Makefile.in
@@ -206,7 +206,7 @@ refcheck:
install:
mkdir -p $(DESTDIR)/$(MANDIR)/man3 || exit
- cp *$(GZIP_SUFFIX) $(DESTDIR)/$(MANDIR)/man3 || exit
+ cp -p *$(GZIP_SUFFIX) $(DESTDIR)/$(MANDIR)/man3 || exit
uninstall:
for target in $(OBJECTS); do \
diff --git a/doc/ck_epoch_barrier b/doc/ck_epoch_barrier
index a586145..2343800 100644
--- a/doc/ck_epoch_barrier
+++ b/doc/ck_epoch_barrier
@@ -68,7 +68,7 @@ function(void)
ck_stack_entry_t *s;
record = malloc(sizeof *record);
- ck_epoch_register(&epoch, record);
+ ck_epoch_register(&epoch, record, NULL);
/*
* We are using an epoch section here to guarantee no
diff --git a/doc/ck_epoch_call b/doc/ck_epoch_call
index 7390642..fb6302d 100644
--- a/doc/ck_epoch_call
+++ b/doc/ck_epoch_call
@@ -89,7 +89,7 @@ function(void)
struct object *n;
record = malloc(sizeof *record);
- ck_epoch_register(&epoch, record);
+ ck_epoch_register(&epoch, record, NULL);
n = malloc(sizeof *n);
if (n == NULL)
diff --git a/doc/ck_epoch_init b/doc/ck_epoch_init
index 51a3e2a..c7dee9f 100644
--- a/doc/ck_epoch_init
+++ b/doc/ck_epoch_init
@@ -51,7 +51,7 @@ The behavior of
is undefined if
.Fa epoch
is not a pointer to a
-.Tn ck_epoch_t
+.Vt ck_epoch_t
object.
.El
.Sh SEE ALSO
diff --git a/doc/ck_epoch_recycle b/doc/ck_epoch_recycle
index 530079c..cfaa9f3 100644
--- a/doc/ck_epoch_recycle
+++ b/doc/ck_epoch_recycle
@@ -64,7 +64,7 @@ function(void)
if (record == NULL)
return;
- ck_epoch_register(&epoch, record);
+ ck_epoch_register(&epoch, record, NULL);
}
/*
diff --git a/doc/ck_epoch_synchronize b/doc/ck_epoch_synchronize
index 6e5f73d..7b4bf74 100644
--- a/doc/ck_epoch_synchronize
+++ b/doc/ck_epoch_synchronize
@@ -73,7 +73,7 @@ function(void)
ck_stack_entry_t *s;
record = malloc(sizeof *record);
- ck_epoch_register(&epoch, record);
+ ck_epoch_register(&epoch, record, NULL);
/*
* We are using an epoch section here to guarantee no
diff --git a/doc/ck_hs_init b/doc/ck_hs_init
index cfcbf63..9bff896 100644
--- a/doc/ck_hs_init
+++ b/doc/ck_hs_init
@@ -143,7 +143,7 @@ The behavior of
is undefined if
.Fa hs
is not a pointer to a
-.Tn ck_hs_t
+.Vt ck_hs_t
object.
.El
.Sh SEE ALSO
diff --git a/doc/ck_ht_init b/doc/ck_ht_init
index 757a39a..5382c03 100644
--- a/doc/ck_ht_init
+++ b/doc/ck_ht_init
@@ -68,7 +68,7 @@ NULL or (void *)UINTPTR_MAX will result in undefined behavior.
.It CK_HT_MODE_DIRECT
The hash table is meant to store key-value pointers where
the key is of fixed width field compatible with the
-.Tn uintptr_t
+.Vt uintptr_t
type. The key will be directly compared with other keys for
equality. Entries of this hash table are expected to be interacted
with using the
@@ -155,7 +155,7 @@ The behavior of
is undefined if
.Fa ht
is not a pointer to a
-.Tn ck_ht_t
+.Vt ck_ht_t
object.
.El
.Sh SEE ALSO
diff --git a/doc/ck_pr_fence_atomic_store b/doc/ck_pr_fence_atomic_store
index fd02122..9cd8dc5 100644
--- a/doc/ck_pr_fence_atomic_store
+++ b/doc/ck_pr_fence_atomic_store
@@ -42,7 +42,7 @@ The
.Fn ck_pr_fence_atomic_store
function enforces the ordering of any
atomic read-modify-write operations relative to
-any load operations following the function invocation. This function
+any store operations following the function invocation. This function
always serve as an implicit compiler barrier. On
architectures implementing CK_MD_TSO, this operation
only serves as a compiler barrier and no fences
diff --git a/doc/ck_queue b/doc/ck_queue
index a27ec15..df0276a 100644
--- a/doc/ck_queue
+++ b/doc/ck_queue
@@ -31,6 +31,7 @@
.Nm CK_LIST_ENTRY ,
.Nm CK_LIST_FIRST ,
.Nm CK_LIST_FOREACH ,
+.Nm CK_LIST_FOREACH_FROM ,
.Nm CK_LIST_FOREACH_SAFE ,
.Nm CK_LIST_HEAD ,
.Nm CK_LIST_HEAD_INITIALIZER ,
@@ -46,6 +47,7 @@
.Nm CK_SLIST_ENTRY ,
.Nm CK_SLIST_FIRST ,
.Nm CK_SLIST_FOREACH ,
+.Nm CK_SLIST_FOREACH_FROM ,
.Nm CK_SLIST_FOREACH_PREVPTR ,
.Nm CK_SLIST_FOREACH_SAFE ,
.Nm CK_SLIST_HEAD ,
@@ -64,6 +66,7 @@
.Nm CK_STAILQ_ENTRY ,
.Nm CK_STAILQ_FIRST ,
.Nm CK_STAILQ_FOREACH ,
+.Nm CK_STAILQ_FOREACH_FROM ,
.Nm CK_STAILQ_FOREACH_SAFE ,
.Nm CK_STAILQ_HEAD ,
.Nm CK_STAILQ_HEAD_INITIALIZER ,
@@ -86,6 +89,7 @@ Concurrency Kit (libck, \-lck)
.Fn CK_LIST_ENTRY
.Fn CK_LIST_FIRST
.Fn CK_LIST_FOREACH
+.Fn CK_LIST_FOREACH_FROM
.Fn CK_LIST_FOREACH_SAFE
.Fn CK_LIST_HEAD
.Fn CK_LIST_HEAD_INITIALIZER
@@ -101,6 +105,7 @@ Concurrency Kit (libck, \-lck)
.Fn CK_SLIST_ENTRY
.Fn CK_SLIST_FIRST
.Fn CK_SLIST_FOREACH
+.Fn CK_SLIST_FOREACH_FROM
.Fn CK_SLIST_FOREACH_PREVPTR
.Fn CK_SLIST_FOREACH_SAFE
.Fn CK_SLIST_HEAD
@@ -119,6 +124,7 @@ Concurrency Kit (libck, \-lck)
.Fn CK_STAILQ_ENTRY
.Fn CK_STAILQ_FIRST
.Fn CK_STAILQ_FOREACH
+.Fn CK_STAILQ_FOREACH_FROM
.Fn CK_STAILQ_FOREACH_SAFE
.Fn CK_STAILQ_HEAD
.Fn CK_STAILQ_HEAD_INITIALIZER
diff --git a/doc/ck_rhs_init b/doc/ck_rhs_init
index 17c5097..b8316d3 100644
--- a/doc/ck_rhs_init
+++ b/doc/ck_rhs_init
@@ -140,7 +140,7 @@ The behavior of
is undefined if
.Fa hs
is not a pointer to a
-.Tn ck_rhs_t
+.Vt ck_rhs_t
object.
.El
.Sh SEE ALSO