summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 70667c5..e91561b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,6 +15,12 @@ ifeq ($(DEB_HOST_ARCH), i386)
PLATFORM = --disable-sse
endif
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+ NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+else
+ NUMJOBS = 1
+endif
+
%:
dh ${@}
@@ -37,5 +43,7 @@ override_dh_auto_configure:
override_dh_auto_test:
ifneq (,$(filter $(DEB_HOST_ARCH), amd64 arm64 i386))
+ifneq ($(NUMJOBS), 1)
$(MAKE) -j1 check
endif
+endif