summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index ee6a3be..e8da4e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,12 @@
include /usr/share/dpkg/architecture.mk
-ifeq ($(DEB_BUILD_ARCH),armel)
- PLATFORM = --platform=armv7l
+ifneq (,$(filter $(DEB_HOST_ARCH), armel x32))
+ PLATFORM = --platform=unknown
+endif
+
+ifeq ($(DEB_HOST_ARCH), i386)
+ PLATFORM = --disable-sse
endif
%:
@@ -16,7 +20,7 @@ override_dh_auto_configure:
--includedir=/usr/include \
--mandir=/usr/share/man \
--cores=2 \
- --disable-sse $(PLATFORM)
+ $(PLATFORM)
override_dh_auto_test:
$(MAKE) -j1 check