summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-09-06 04:12:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-09-06 04:13:23 +0000
commit3fb37a1d0237869e8e37864d06c0dfd94bb43189 (patch)
treeda8700e80772bd4c9605f263a3299a54d96f636b /setup.py
parentReleasing debian version 2.1.0-2. (diff)
downloadcli-helpers-3fb37a1d0237869e8e37864d06c0dfd94bb43189.tar.xz
cli-helpers-3fb37a1d0237869e8e37864d06c0dfd94bb43189.zip
Merging upstream version 2.2.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py62
1 files changed, 29 insertions, 33 deletions
diff --git a/setup.py b/setup.py
index 6cf886f..46fbdc8 100755
--- a/setup.py
+++ b/setup.py
@@ -8,11 +8,12 @@ import sys
from setuptools import find_packages, setup
-_version_re = re.compile(r'__version__\s+=\s+(.*)')
+_version_re = re.compile(r"__version__\s+=\s+(.*)")
-with open('cli_helpers/__init__.py', 'rb') as f:
- version = str(ast.literal_eval(_version_re.search(
- f.read().decode('utf-8')).group(1)))
+with open("cli_helpers/__init__.py", "rb") as f:
+ version = str(
+ ast.literal_eval(_version_re.search(f.read().decode("utf-8")).group(1))
+ )
def open_file(filename):
@@ -21,42 +22,37 @@ def open_file(filename):
return f.read()
-readme = open_file('README.rst')
-
-if sys.version_info[0] == 2:
- py2_reqs = ['backports.csv >= 1.0.0']
-else:
- py2_reqs = []
+readme = open_file("README.rst")
setup(
- name='cli_helpers',
- author='dbcli',
- author_email='thomas@roten.us',
+ name="cli_helpers",
+ author="dbcli",
+ author_email="thomas@roten.us",
version=version,
- url='https://github.com/dbcli/cli_helpers',
- packages=find_packages(exclude=['docs', 'tests', 'tests.tabular_output']),
+ url="https://github.com/dbcli/cli_helpers",
+ packages=find_packages(exclude=["docs", "tests", "tests.tabular_output"]),
include_package_data=True,
- description='Helpers for building command-line apps',
+ description="Helpers for building command-line apps",
long_description=readme,
- long_description_content_type='text/x-rst',
+ long_description_content_type="text/x-rst",
install_requires=[
- 'configobj >= 5.0.5',
- 'tabulate[widechars] >= 0.8.2',
- 'terminaltables >= 3.0.0',
- ] + py2_reqs,
+ "configobj >= 5.0.5",
+ "tabulate[widechars] >= 0.8.2",
+ ],
extras_require={
- 'styles': ['Pygments >= 1.6'],
+ "styles": ["Pygments >= 1.6"],
},
+ python_requires=">=3.6",
classifiers=[
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Operating System :: Unix',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Topic :: Software Development',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: Terminals :: Terminal Emulators/X Terminals',
- ]
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: Unix",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Topic :: Software Development",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Terminals :: Terminal Emulators/X Terminals",
+ ],
)