summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-01-30 08:13:47 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-02-07 10:48:06 +0000
commit57bc0d56d7e741e1e99d96f14e7ab93232440a16 (patch)
tree0d4631d7416ba98b7a414dc825419afd5b177be0 /setup.py
parentInitial commit. (diff)
downloadcli-helpers-57bc0d56d7e741e1e99d96f14e7ab93232440a16.tar.xz
cli-helpers-57bc0d56d7e741e1e99d96f14e7ab93232440a16.zip
Adding upstream version 2.1.0.upstream/2.1.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py62
1 files changed, 62 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6cf886f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,62 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+import ast
+from io import open
+import re
+import sys
+
+from setuptools import find_packages, setup
+
+_version_re = re.compile(r'__version__\s+=\s+(.*)')
+
+with open('cli_helpers/__init__.py', 'rb') as f:
+ version = str(ast.literal_eval(_version_re.search(
+ f.read().decode('utf-8')).group(1)))
+
+
+def open_file(filename):
+ """Open and read the file *filename*."""
+ with open(filename) as f:
+ return f.read()
+
+
+readme = open_file('README.rst')
+
+if sys.version_info[0] == 2:
+ py2_reqs = ['backports.csv >= 1.0.0']
+else:
+ py2_reqs = []
+
+setup(
+ name='cli_helpers',
+ author='dbcli',
+ author_email='thomas@roten.us',
+ version=version,
+ url='https://github.com/dbcli/cli_helpers',
+ packages=find_packages(exclude=['docs', 'tests', 'tests.tabular_output']),
+ include_package_data=True,
+ description='Helpers for building command-line apps',
+ long_description=readme,
+ long_description_content_type='text/x-rst',
+ install_requires=[
+ 'configobj >= 5.0.5',
+ 'tabulate[widechars] >= 0.8.2',
+ 'terminaltables >= 3.0.0',
+ ] + py2_reqs,
+ extras_require={
+ 'styles': ['Pygments >= 1.6'],
+ },
+ classifiers=[
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: Unix',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Software Development',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Terminals :: Terminal Emulators/X Terminals',
+ ]
+)