summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..cfc8d73
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,28 @@
+Source: decko
+Section: web
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ debhelper-compat (= 13),
+ pkg-js-tools,
+Rules-Requires-Root: no
+Standards-Version: 4.6.0
+Homepage: https://github.com/developit/decko
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/decko
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/decko
+
+Package: node-decko
+Section: web
+Architecture: all
+Depends:
+ ${misc:Depends},
+Description: useful Javascript decorators
+ Decorators help simplify code by replacing the noise of common patterns with
+ declarative annotations.
+ .
+ Decko establishes 3 standard decorators that are immediately recognizable, so
+ you can avoid creating decorators in your own codebase:
+ .
+ * @bind: make the value of this constant within a method
+ * @debounce: throttle calls to a method
+ * @memoize: cache return values based on arguments