summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-24 17:48:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-24 18:03:58 +0000
commit9e23ee4daa1037da52b0076f59537c12c9618c52 (patch)
tree38c5e0401923ae8089885269099f70cc2eb275c6 /debian/rules
parentAdding build-depends to pybuild-plugin-pyproject for PEP517 support. (diff)
downloaddeluge-9e23ee4daa1037da52b0076f59537c12c9618c52.tar.xz
deluge-9e23ee4daa1037da52b0076f59537c12c9618c52.zip
Updating packaging for new upstream version.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 10 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index 846c76e..8f33b31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,25 +2,22 @@
SHELL := sh -e
+VERSION := $(shell dpkg-parsechangelog -SVersion | sed -e 's|~dev|.dev|' -e 's|+.*||')
+
%:
dh ${@} --buildsystem=pybuild --with=python3
-execute_after_dh_auto_test:
- find . -type d -name '*.egg-info' | xargs rm -rf
- find . -type d -name '.eggs' | xargs rm -rf
- find . -type d -wholename './deluge/plugins/*/build' | xargs rm -rf
-
- rm -f deluge/data/share/applications/deluge.desktop
+execute_after_dh_auto_clean:
+ rm -f RELEASE-VERSION
-override_dh_auto_build:
- python3 setup.py build
+execute_before_dh_auto_build:
+ echo "$(VERSION)" > RELEASE-VERSION
override_dh_auto_test:
# disabled
-override_dh_auto_install:
- python3 setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
-
+execute_after_dh_auto_install:
+ # unpacking plugins
cd debian/tmp/usr/lib/python*/*-packages/deluge/plugins/; \
for EGG in *.egg; \
do \
@@ -29,4 +26,5 @@ override_dh_auto_install:
rm -f $${EGG}; \
done
- find . -type d -name '__pycache__' | xargs rm -rf
+ # removing unused files
+ find debian/tmp -type d -name '__pycache__' | xargs rm -rf