summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control185
1 files changed, 104 insertions, 81 deletions
diff --git a/debian/control b/debian/control
index 6d58c68..1eeabe9 100644
--- a/debian/control
+++ b/debian/control
@@ -2,38 +2,33 @@ Source: deluge
Section: net
Priority: optional
Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
-Build-Depends-Indep: dh-python,
- intltool,
- python3-all,
- python3-setuptools,
- python3-wheel,
- unzip
+Build-Depends:
+ debhelper-compat (= 13),
+Build-Depends-Indep:
+ dh-python,
+ intltool,
+ python3-all,
+ python3-setuptools,
+ python3-wheel,
+ unzip,
Rules-Requires-Root: no
Standards-Version: 4.6.2
Homepage: https://deluge-torrent.org
Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/deluge
Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/deluge
-Build-Depends: debhelper-compat (= 13)
-Package: deluge-common
+Package: deluge
Architecture: all
-Depends: ${misc:Depends},
- ${python3:Depends},
- python3-six,
- python3-twisted (>= 11.1),
- python3-openssl,
- python3-pkg-resources,
- python3-chardet,
- python3-xdg,
- python3-rencode
-Recommends: python3-setproctitle,
- python3-pil,
- python3-geoip,
- geoip-database,
- python3-dbus
-Breaks: deluge-torrent-common (<< 1.0.7.dfsg-1), deluge-torrent (<< 1.0.7.dfsg-1), deluge-core (<< 1.2.0~rc1-1)
-Replaces: deluge-torrent-common (<< 1.0.7.dfsg-1), deluge-torrent (<< 1.0.7.dfsg-1), deluge-core (<< 1.2.0~rc1-1)
-Description: bittorrent client written in Python/PyGTK (common files)
+Depends:
+ deluge-gtk (= ${source:Version}),
+ python3-libtorrent (>= 1.1.2),
+ ${misc:Depends},
+ ${python3:Depends},
+Breaks:
+ deluge-common (<< 1.2.0~rc1-1),
+Replaces:
+ deluge-common (<< 1.2.0~rc1-1),
+Description: bittorrent client written in Python/PyGTK
Deluge is a full-featured, multi-platform, multi-interface BitTorrent client
using libtorrent-rasterbar in it's backend and featuring multiple
user-interfaces: GTK+, web and console.
@@ -43,19 +38,36 @@ Description: bittorrent client written in Python/PyGTK (common files)
headless machines with the user-interfaces being able to connect remotely
from any platform.
.
- This package contains data files commons to both the daemon and the
- various user-interfaces.
+ You may want to install this package to use Deluge in classic mode,
+ which means the daemon and the GTK+ user-interface are linked together.
-Package: deluged
+Package: deluge-common
Architecture: all
-Pre-Depends: ${misc:Pre-Depends}
-Depends: ${misc:Depends},
- ${python3:Depends},
- deluge-common (= ${source:Version}),
- python3-libtorrent (>= 1.1.2),
- adduser,
- lsb-base (>= 3.2-14)
-Description: bittorrent client written in Python/PyGTK (daemon)
+Depends:
+ python3-chardet,
+ python3-openssl,
+ python3-pkg-resources,
+ python3-rencode,
+ python3-six,
+ python3-twisted (>= 11.1),
+ python3-xdg,
+ ${misc:Depends},
+ ${python3:Depends},
+Recommends:
+ geoip-database,
+ python3-dbus,
+ python3-geoip,
+ python3-pil,
+ python3-setproctitle,
+Breaks:
+ deluge-core (<< 1.2.0~rc1-1),
+ deluge-torrent (<< 1.0.7.dfsg-1),
+ deluge-torrent-common (<< 1.0.7.dfsg-1),
+Replaces:
+ deluge-core (<< 1.2.0~rc1-1),
+ deluge-torrent (<< 1.0.7.dfsg-1),
+ deluge-torrent-common (<< 1.0.7.dfsg-1),
+Description: bittorrent client written in Python/PyGTK (common files)
Deluge is a full-featured, multi-platform, multi-interface BitTorrent client
using libtorrent-rasterbar in it's backend and featuring multiple
user-interfaces: GTK+, web and console.
@@ -65,16 +77,16 @@ Description: bittorrent client written in Python/PyGTK (daemon)
headless machines with the user-interfaces being able to connect remotely
from any platform.
.
- You may want to install this package to run the daemon application on a remote
- server and connect to it from any user-interface.
- See: <URL:http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient>
+ This package contains data files commons to both the daemon and the
+ various user-interfaces.
Package: deluge-console
Architecture: all
-Depends: ${misc:Depends},
- ${python3:Depends},
- python3-libtorrent (>= 1.1.2),
- deluge-common (= ${source:Version})
+Depends:
+ deluge-common (= ${source:Version}),
+ python3-libtorrent (>= 1.1.2),
+ ${misc:Depends},
+ ${python3:Depends},
Description: bittorrent client written in Python/PyGTK (console ui)
Deluge is a full-featured, multi-platform, multi-interface BitTorrent client
using libtorrent-rasterbar in it's backend and featuring multiple
@@ -87,15 +99,27 @@ Description: bittorrent client written in Python/PyGTK (console ui)
.
This package contains the console user-interface.
-Package: deluge-web
+Package: deluge-gtk
Architecture: all
-Depends: ${misc:Depends},
- ${python3:Depends},
- deluge-common (= ${source:Version}),
- python3-mako
-Breaks: deluge-webui (<< 1.2.0~rc1-1)
-Replaces: deluge-webui (<< 1.2.0~rc1-1)
-Description: bittorrent client written in Python/PyGTK (web ui)
+Depends:
+ deluge-common (= ${source:Version}),
+ gir1.2-gtk-3.0,
+ libnotify4,
+ librsvg2-common,
+ python3-gi,
+ python3-gi-cairo,
+ xdg-utils,
+ ${misc:Depends},
+ ${python3:Depends},
+Breaks:
+ deluge (<< 1.2.0-1),
+Replaces:
+ deluge (<< 1.2.0-1),
+Recommends:
+ gir1.2-appindicator3-0.1,
+ python3-pygame,
+ ${dist:Recommends},
+Description: bittorrent client written in Python/PyGTK (GTK+ ui)
Deluge is a full-featured, multi-platform, multi-interface BitTorrent client
using libtorrent-rasterbar in it's backend and featuring multiple
user-interfaces: GTK+, web and console.
@@ -105,27 +129,22 @@ Description: bittorrent client written in Python/PyGTK (web ui)
headless machines with the user-interfaces being able to connect remotely
from any platform.
.
- You may want to install this package on a remote server running the deluge
- daemon (package deluged).
+ You may want to install this package to use the Deluge GTK+ user-interface
+ as a thin client and connect to a remote daemon.
See: <URL:http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient>
-Package: deluge-gtk
+Package: deluge-web
Architecture: all
-Depends: ${misc:Depends},
- ${python3:Depends},
- deluge-common (= ${source:Version}),
- python3-gi,
- python3-gi-cairo,
- gir1.2-gtk-3.0,
- libnotify4,
- librsvg2-common,
- xdg-utils
-Breaks: deluge (<< 1.2.0-1)
-Replaces: deluge (<< 1.2.0-1)
-Recommends: ${dist:Recommends},
- gir1.2-appindicator3-0.1,
- python3-pygame
-Description: bittorrent client written in Python/PyGTK (GTK+ ui)
+Depends:
+ deluge-common (= ${source:Version}),
+ python3-mako,
+ ${misc:Depends},
+ ${python3:Depends},
+Breaks:
+ deluge-webui (<< 1.2.0~rc1-1),
+Replaces:
+ deluge-webui (<< 1.2.0~rc1-1),
+Description: bittorrent client written in Python/PyGTK (web ui)
Deluge is a full-featured, multi-platform, multi-interface BitTorrent client
using libtorrent-rasterbar in it's backend and featuring multiple
user-interfaces: GTK+, web and console.
@@ -135,19 +154,22 @@ Description: bittorrent client written in Python/PyGTK (GTK+ ui)
headless machines with the user-interfaces being able to connect remotely
from any platform.
.
- You may want to install this package to use the Deluge GTK+ user-interface
- as a thin client and connect to a remote daemon.
+ You may want to install this package on a remote server running the deluge
+ daemon (package deluged).
See: <URL:http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient>
-Package: deluge
+Package: deluged
Architecture: all
-Depends: ${misc:Depends},
- ${python3:Depends},
- python3-libtorrent (>= 1.1.2),
- deluge-gtk (= ${source:Version})
-Breaks: deluge-common (<< 1.2.0~rc1-1)
-Replaces: deluge-common (<< 1.2.0~rc1-1)
-Description: bittorrent client written in Python/PyGTK
+Pre-Depends:
+ ${misc:Pre-Depends},
+Depends:
+ adduser,
+ deluge-common (= ${source:Version}),
+ lsb-base (>= 3.2-14),
+ python3-libtorrent (>= 1.1.2),
+ ${misc:Depends},
+ ${python3:Depends},
+Description: bittorrent client written in Python/PyGTK (daemon)
Deluge is a full-featured, multi-platform, multi-interface BitTorrent client
using libtorrent-rasterbar in it's backend and featuring multiple
user-interfaces: GTK+, web and console.
@@ -157,5 +179,6 @@ Description: bittorrent client written in Python/PyGTK
headless machines with the user-interfaces being able to connect remotely
from any platform.
.
- You may want to install this package to use Deluge in classic mode,
- which means the daemon and the GTK+ user-interface are linked together.
+ You may want to install this package to run the daemon application on a remote
+ server and connect to it from any user-interface.
+ See: <URL:http://dev.deluge-torrent.org/wiki/UserGuide/ThinClient>