summaryrefslogtreecommitdiffstats
path: root/deluge/plugins/Notifications
diff options
context:
space:
mode:
Diffstat (limited to 'deluge/plugins/Notifications')
-rwxr-xr-xdeluge/plugins/Notifications/create_dev_link.sh11
-rw-r--r--deluge/plugins/Notifications/deluge_notifications/webui.py1
2 files changed, 11 insertions, 1 deletions
diff --git a/deluge/plugins/Notifications/create_dev_link.sh b/deluge/plugins/Notifications/create_dev_link.sh
new file mode 100755
index 0000000..5e04057
--- /dev/null
+++ b/deluge/plugins/Notifications/create_dev_link.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+BASEDIR=$(cd `dirname $0` && pwd)
+CONFIG_DIR=$( test -z $1 && echo "" || echo "$1")
+[ -d "$CONFIG_DIR/plugins" ] || echo "Config dir "$CONFIG_DIR" is either not a directory or is not a proper deluge config directory. Exiting"
+[ -d "$CONFIG_DIR/plugins" ] || exit 1
+cd $BASEDIR
+test -d $BASEDIR/temp || mkdir $BASEDIR/temp
+export PYTHONPATH=$BASEDIR/temp
+python setup.py build develop --install-dir $BASEDIR/temp
+cp $BASEDIR/temp/*.egg-link $CONFIG_DIR/plugins
+rm -fr $BASEDIR/temp
diff --git a/deluge/plugins/Notifications/deluge_notifications/webui.py b/deluge/plugins/Notifications/deluge_notifications/webui.py
index ad090f5..bf3e829 100644
--- a/deluge/plugins/Notifications/deluge_notifications/webui.py
+++ b/deluge/plugins/Notifications/deluge_notifications/webui.py
@@ -21,7 +21,6 @@ log = logging.getLogger(__name__)
class WebUI(WebPluginBase):
-
scripts = [get_resource('notifications.js')]
debug_scripts = scripts