summaryrefslogtreecommitdiffstats
path: root/.copr/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-17 07:11:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-17 07:11:16 +0000
commita68848db159cc1cafa82f9d383432fda459c8745 (patch)
tree5fd1cd2cd6f298bebbbb0ce5db29fa6de68a2acc /.copr/Makefile
parentAdding debian version 1.1.0+debian-1. (diff)
downloaddnsjit-a68848db159cc1cafa82f9d383432fda459c8745.tar.xz
dnsjit-a68848db159cc1cafa82f9d383432fda459c8745.zip
Merging upstream version 1.2.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.copr/Makefile')
-rw-r--r--.copr/Makefile23
1 files changed, 0 insertions, 23 deletions
diff --git a/.copr/Makefile b/.copr/Makefile
deleted file mode 100644
index 29ed0bc..0000000
--- a/.copr/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-top=..
-
-all: srpm
-
-prereq: $(top)/rpmbuild
- rpm -q git rpm-build >/dev/null || dnf -y install git rpm-build
-
-update-dist-tools: $(top)/dist-tools
- ( cd "$(top)/dist-tools" && git pull )
-
-$(top)/dist-tools:
- git clone https://github.com/jelu/dist-tools.git "$(top)/dist-tools"
-
-$(top)/rpmbuild:
- mkdir -p "$(top)"/rpmbuild/{BUILD,RPMS,SOURCES,SPECS,SRPMS}
-
-srpm: prereq update-dist-tools
- test -f .gitmodules && git submodule update --init || true
- echo "$(spec)" | grep -q "develop.spec" && auto_build_number=`date --utc +%s` message="Auto build `date --utc --iso-8601=seconds`" "$(top)/dist-tools/spec-new-changelog-entry" || true
- overwrite=yes nosign=yes "$(top)/dist-tools/create-source-packages" rpm
- cp ../*.orig.tar.gz "$(top)/rpmbuild/SOURCES/"
- echo "$(spec)" | grep -q "develop.spec" && rpmbuild -bs --define "%_topdir $(top)/rpmbuild" --undefine=dist rpm/*.spec || rpmbuild -bs --define "%_topdir $(top)/rpmbuild" --undefine=dist "$(spec)"
- cp "$(top)"/rpmbuild/SRPMS/*.src.rpm "$(outdir)"