summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-11-07 13:45:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-11-07 13:45:18 +0000
commit3f7e71c8c57997eb3b1bc778555a7dcf61796c6c (patch)
tree19d76cd0177d3cbc8d0c9af9d7408fa575e11ffd
parentReleasing debian version 1.2.1-3. (diff)
downloaddnsjit-3f7e71c8c57997eb3b1bc778555a7dcf61796c6c.tar.xz
dnsjit-3f7e71c8c57997eb3b1bc778555a7dcf61796c6c.zip
Merging upstream version 1.2.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGES10
-rwxr-xr-xconfigure22
-rw-r--r--configure.ac4
-rw-r--r--include/dnsjit/core/compat.c4
-rw-r--r--include/dnsjit/gen-compat.lua1
-rw-r--r--include/dnsjit/version.h2
-rw-r--r--src/core/compat.c4
-rw-r--r--src/gen-compat.lua1
-rw-r--r--src/version.h2
9 files changed, 27 insertions, 23 deletions
diff --git a/CHANGES b/CHANGES
index c37dabd..6259204 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,13 @@
+2021-11-05 Jerry Lundström
+
+ Release 1.2.2
+
+ This patch release fixes a small issues with the generated
+ compatibility code and updates the package control files for Debian.
+
+ 3cdd801 Fix compat
+ cb352c6 debhelper
+
2021-07-07 Jerry Lundström
Release 1.2.1
diff --git a/configure b/configure
index 44ef44d..e52afbf 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for dnsjit 1.2.1.
+# Generated by GNU Autoconf 2.69 for dnsjit 1.2.2.
#
# Report bugs to <admin@dns-oarc.net>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='dnsjit'
PACKAGE_TARNAME='dnsjit'
-PACKAGE_VERSION='1.2.1'
-PACKAGE_STRING='dnsjit 1.2.1'
+PACKAGE_VERSION='1.2.2'
+PACKAGE_STRING='dnsjit 1.2.2'
PACKAGE_BUGREPORT='admin@dns-oarc.net'
PACKAGE_URL='https://github.com/DNS-OARC/dnsjit/issues'
@@ -1360,7 +1360,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures dnsjit 1.2.1 to adapt to many kinds of systems.
+\`configure' configures dnsjit 1.2.2 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1431,7 +1431,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of dnsjit 1.2.1:";;
+ short | recursive ) echo "Configuration of dnsjit 1.2.2:";;
esac
cat <<\_ACEOF
@@ -1566,7 +1566,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-dnsjit configure 1.2.1
+dnsjit configure 1.2.2
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2172,7 +2172,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by dnsjit $as_me 1.2.1, which was
+It was created by dnsjit $as_me 1.2.2, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2527,7 +2527,7 @@ $as_echo "#define PACKAGE_MAJOR_VERSION 1" >>confdefs.h
$as_echo "#define PACKAGE_MINOR_VERSION 2" >>confdefs.h
-$as_echo "#define PACKAGE_PATCH_VERSION 1" >>confdefs.h
+$as_echo "#define PACKAGE_PATCH_VERSION 2" >>confdefs.h
am__api_version='1.16'
@@ -3044,7 +3044,7 @@ fi
# Define the identity of the package.
PACKAGE='dnsjit'
- VERSION='1.2.1'
+ VERSION='1.2.2'
cat >>confdefs.h <<_ACEOF
@@ -16132,7 +16132,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by dnsjit $as_me 1.2.1, which was
+This file was extended by dnsjit $as_me 1.2.2, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -16199,7 +16199,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-dnsjit config.status 1.2.1
+dnsjit config.status 1.2.2
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
diff --git a/configure.ac b/configure.ac
index b3838af..b7dab7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,10 +17,10 @@
# along with dnsjit. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.64)
-AC_INIT([dnsjit], [1.2.1], [admin@dns-oarc.net], [dnsjit], [https://github.com/DNS-OARC/dnsjit/issues])
+AC_INIT([dnsjit], [1.2.2], [admin@dns-oarc.net], [dnsjit], [https://github.com/DNS-OARC/dnsjit/issues])
AC_DEFINE([PACKAGE_MAJOR_VERSION], [1], [Define to the major version of this package.])
AC_DEFINE([PACKAGE_MINOR_VERSION], [2], [Define to the minor version of this package.])
-AC_DEFINE([PACKAGE_PATCH_VERSION], [1], [Define to the patch version of this package.])
+AC_DEFINE([PACKAGE_PATCH_VERSION], [2], [Define to the patch version of this package.])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AC_CONFIG_SRCDIR([src/dnsjit.c])
AC_CONFIG_HEADER([src/config.h])
diff --git a/include/dnsjit/core/compat.c b/include/dnsjit/core/compat.c
index 9f2be98..578d34d 100644
--- a/include/dnsjit/core/compat.c
+++ b/include/dnsjit/core/compat.c
@@ -20,6 +20,4 @@
#include "config.h"
-#include <stdint.h>
-
-#include "core/compat.hh"
+#include "core/compat.h"
diff --git a/include/dnsjit/gen-compat.lua b/include/dnsjit/gen-compat.lua
index 65c40ec..54de9da 100644
--- a/include/dnsjit/gen-compat.lua
+++ b/include/dnsjit/gen-compat.lua
@@ -27,7 +27,6 @@ code, err = pcall(function()
]]
end)
if code then
- print("#include <unistd.h>")
print("typedef ssize_t luajit_ssize_t;")
else
print("typedef long luajit_ssize_t;")
diff --git a/include/dnsjit/version.h b/include/dnsjit/version.h
index c53bdf3..30a2a3e 100644
--- a/include/dnsjit/version.h
+++ b/include/dnsjit/version.h
@@ -23,6 +23,6 @@
#define DNSJIT_MAJOR_VERSION 1
#define DNSJIT_MINOR_VERSION 2
-#define DNSJIT_PATCH_VERSION 1
+#define DNSJIT_PATCH_VERSION 2
#endif
diff --git a/src/core/compat.c b/src/core/compat.c
index 9f2be98..578d34d 100644
--- a/src/core/compat.c
+++ b/src/core/compat.c
@@ -20,6 +20,4 @@
#include "config.h"
-#include <stdint.h>
-
-#include "core/compat.hh"
+#include "core/compat.h"
diff --git a/src/gen-compat.lua b/src/gen-compat.lua
index 65c40ec..54de9da 100644
--- a/src/gen-compat.lua
+++ b/src/gen-compat.lua
@@ -27,7 +27,6 @@ code, err = pcall(function()
]]
end)
if code then
- print("#include <unistd.h>")
print("typedef ssize_t luajit_ssize_t;")
else
print("typedef long luajit_ssize_t;")
diff --git a/src/version.h b/src/version.h
index c53bdf3..30a2a3e 100644
--- a/src/version.h
+++ b/src/version.h
@@ -23,6 +23,6 @@
#define DNSJIT_MAJOR_VERSION 1
#define DNSJIT_MINOR_VERSION 2
-#define DNSJIT_PATCH_VERSION 1
+#define DNSJIT_PATCH_VERSION 2
#endif