summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-03 07:49:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-03 07:49:53 +0000
commit9ed2732784a3330f8832de59124a78401cd6500f (patch)
tree12338459dad59bd39178051e375661e9c47b3775 /configure.ac
parentReleasing debian version 1.3.0-2. (diff)
downloaddnsjit-9ed2732784a3330f8832de59124a78401cd6500f.tar.xz
dnsjit-9ed2732784a3330f8832de59124a78401cd6500f.zip
Merging upstream version 1.4.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7627712..8a5344c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# Copyright (c) 2018-2023, OARC, Inc.
+# Copyright (c) 2018-2024 OARC, Inc.
# All rights reserved.
#
# This file is part of dnsjit.
@@ -17,9 +17,9 @@
# along with dnsjit. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ(2.64)
-AC_INIT([dnsjit], [1.3.0], [admin@dns-oarc.net], [dnsjit], [https://github.com/DNS-OARC/dnsjit/issues])
+AC_INIT([dnsjit], [1.4.0], [admin@dns-oarc.net], [dnsjit], [https://github.com/DNS-OARC/dnsjit/issues])
AC_DEFINE([PACKAGE_MAJOR_VERSION], [1], [Define to the major version of this package.])
-AC_DEFINE([PACKAGE_MINOR_VERSION], [3], [Define to the minor version of this package.])
+AC_DEFINE([PACKAGE_MINOR_VERSION], [4], [Define to the minor version of this package.])
AC_DEFINE([PACKAGE_PATCH_VERSION], [0], [Define to the patch version of this package.])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AC_CONFIG_SRCDIR([src/dnsjit.c])
@@ -92,6 +92,8 @@ PKG_CHECK_MODULES([gnutls], [gnutls],, [
])
PKG_CHECK_MODULES([liblz4], [liblz4 >= 1.8.0 liblz4 != 131], [AC_DEFINE([HAVE_LZ4], [], [Use liblz4])],:)
PKG_CHECK_MODULES([libzstd], [libzstd >= 1.3.0], [AC_DEFINE([HAVE_ZSTD], [], [Use libzstd])],:)
+AC_CHECK_LIB([z], [gzopen],, [AC_MSG_ERROR([zlib not found])])
+PKG_CHECK_MODULES([liblzma], [liblzma >= 5.2.0], [AC_DEFINE([HAVE_LZMA], [], [Use liblzma])],:)
# Checks for sizes
AC_CHECK_SIZEOF([void*])