summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-12 09:19:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-12 09:19:20 +0000
commitb6d97fef4669d07c108b130ea882f19a737d2ae9 (patch)
treec2f7a4e2e0ba7f963db3a9041d4644e70bd0024c /configure.ac
parentUpdating watch file. (diff)
downloaddnsperf-b6d97fef4669d07c108b130ea882f19a737d2ae9.tar.xz
dnsperf-b6d97fef4669d07c108b130ea882f19a737d2ae9.zip
Merging upstream version 2.7.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d5bb80..c8f6029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@
# limitations under the License.
AC_PREREQ(2.64)
-AC_INIT([dnsperf], [2.6.0], [admin@dns-oarc.net], [dnsperf], [https://github.com/DNS-OARC/dnsperf/issues])
+AC_INIT([dnsperf], [2.7.0], [admin@dns-oarc.net], [dnsperf], [https://github.com/DNS-OARC/dnsperf/issues])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AC_CONFIG_SRCDIR([src/dnsperf.c])
AC_CONFIG_HEADER([src/config.h])
@@ -77,6 +77,15 @@ PKG_CHECK_MODULES([libldns], [libldns >= 1.7.0], [AC_DEFINE([HAVE_LDNS], [1], [D
])
])
+# Check for nghttp2
+PKG_CHECK_MODULES([libnghttp2], [libnghttp2 >= 0], [
+ AS_VAR_APPEND([CFLAGS], [" $nghttp2_CFLAGS"])
+ AS_VAR_APPEND([LIBS], [" $nghttp2_LIBS"])
+], [
+ AC_CHECK_HEADERS([nghttp2.h],, [AC_MSG_ERROR([nghttp2 headers not found])])
+ AC_CHECK_LIB([nghttp2], [nghttp2_session],, [AC_MSG_ERROR([nghttp2 not found])])
+])
+
# Output Makefiles
AC_CONFIG_FILES([
Makefile