summaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-12 09:19:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-08-12 09:19:20 +0000
commitb6d97fef4669d07c108b130ea882f19a737d2ae9 (patch)
treec2f7a4e2e0ba7f963db3a9041d4644e70bd0024c /configure
parentUpdating watch file. (diff)
downloaddnsperf-b6d97fef4669d07c108b130ea882f19a737d2ae9.tar.xz
dnsperf-b6d97fef4669d07c108b130ea882f19a737d2ae9.zip
Merging upstream version 2.7.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure230
1 files changed, 219 insertions, 11 deletions
diff --git a/configure b/configure
index 2720add..2f1bd71 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for dnsperf 2.6.0.
+# Generated by GNU Autoconf 2.69 for dnsperf 2.7.0.
#
# Report bugs to <admin@dns-oarc.net>.
#
@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='dnsperf'
PACKAGE_TARNAME='dnsperf'
-PACKAGE_VERSION='2.6.0'
-PACKAGE_STRING='dnsperf 2.6.0'
+PACKAGE_VERSION='2.7.0'
+PACKAGE_STRING='dnsperf 2.7.0'
PACKAGE_BUGREPORT='admin@dns-oarc.net'
PACKAGE_URL='https://github.com/DNS-OARC/dnsperf/issues'
@@ -636,6 +636,8 @@ ac_subst_vars='am__EXEEXT_FALSE
am__EXEEXT_TRUE
LTLIBOBJS
LIBOBJS
+libnghttp2_LIBS
+libnghttp2_CFLAGS
libldns_LIBS
libldns_CFLAGS
ck_LIBS
@@ -805,7 +807,9 @@ libcrypto_LIBS
ck_CFLAGS
ck_LIBS
libldns_CFLAGS
-libldns_LIBS'
+libldns_LIBS
+libnghttp2_CFLAGS
+libnghttp2_LIBS'
# Initialize some variables set by options.
@@ -1356,7 +1360,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures dnsperf 2.6.0 to adapt to many kinds of systems.
+\`configure' configures dnsperf 2.7.0 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1427,7 +1431,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of dnsperf 2.6.0:";;
+ short | recursive ) echo "Configuration of dnsperf 2.7.0:";;
esac
cat <<\_ACEOF
@@ -1494,6 +1498,10 @@ Some influential environment variables:
C compiler flags for libldns, overriding pkg-config
libldns_LIBS
linker flags for libldns, overriding pkg-config
+ libnghttp2_CFLAGS
+ C compiler flags for libnghttp2, overriding pkg-config
+ libnghttp2_LIBS
+ linker flags for libnghttp2, overriding pkg-config
Use these variables to override the choices made by `configure' or to help
it to find libraries and programs with nonstandard names/locations.
@@ -1562,7 +1570,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-dnsperf configure 2.6.0
+dnsperf configure 2.7.0
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -1931,7 +1939,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by dnsperf $as_me 2.6.0, which was
+It was created by dnsperf $as_me 2.7.0, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -2794,7 +2802,7 @@ fi
# Define the identity of the package.
PACKAGE='dnsperf'
- VERSION='2.6.0'
+ VERSION='2.7.0'
cat >>confdefs.h <<_ACEOF
@@ -13665,6 +13673,206 @@ $as_echo "#define HAVE_LDNS 1" >>confdefs.h
fi
+# Check for nghttp2
+
+pkg_failed=no
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libnghttp2" >&5
+$as_echo_n "checking for libnghttp2... " >&6; }
+
+if test -n "$libnghttp2_CFLAGS"; then
+ pkg_cv_libnghttp2_CFLAGS="$libnghttp2_CFLAGS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnghttp2 >= 0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "libnghttp2 >= 0") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_libnghttp2_CFLAGS=`$PKG_CONFIG --cflags "libnghttp2 >= 0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+else
+ pkg_failed=yes
+fi
+ else
+ pkg_failed=untried
+fi
+if test -n "$libnghttp2_LIBS"; then
+ pkg_cv_libnghttp2_LIBS="$libnghttp2_LIBS"
+ elif test -n "$PKG_CONFIG"; then
+ if test -n "$PKG_CONFIG" && \
+ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnghttp2 >= 0\""; } >&5
+ ($PKG_CONFIG --exists --print-errors "libnghttp2 >= 0") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+ pkg_cv_libnghttp2_LIBS=`$PKG_CONFIG --libs "libnghttp2 >= 0" 2>/dev/null`
+ test "x$?" != "x0" && pkg_failed=yes
+else
+ pkg_failed=yes
+fi
+ else
+ pkg_failed=untried
+fi
+
+
+
+if test $pkg_failed = yes; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+
+if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+ _pkg_short_errors_supported=yes
+else
+ _pkg_short_errors_supported=no
+fi
+ if test $_pkg_short_errors_supported = yes; then
+ libnghttp2_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "libnghttp2 >= 0" 2>&1`
+ else
+ libnghttp2_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "libnghttp2 >= 0" 2>&1`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$libnghttp2_PKG_ERRORS" >&5
+
+
+ for ac_header in nghttp2.h
+do :
+ ac_fn_c_check_header_mongrel "$LINENO" "nghttp2.h" "ac_cv_header_nghttp2_h" "$ac_includes_default"
+if test "x$ac_cv_header_nghttp2_h" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_NGHTTP2_H 1
+_ACEOF
+
+else
+ as_fn_error $? "nghttp2 headers not found" "$LINENO" 5
+fi
+
+done
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for nghttp2_session in -lnghttp2" >&5
+$as_echo_n "checking for nghttp2_session in -lnghttp2... " >&6; }
+if ${ac_cv_lib_nghttp2_nghttp2_session+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-lnghttp2 $LIBS"
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char nghttp2_session ();
+int
+main ()
+{
+return nghttp2_session ();
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_lib_nghttp2_nghttp2_session=yes
+else
+ ac_cv_lib_nghttp2_nghttp2_session=no
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_nghttp2_nghttp2_session" >&5
+$as_echo "$ac_cv_lib_nghttp2_nghttp2_session" >&6; }
+if test "x$ac_cv_lib_nghttp2_nghttp2_session" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_LIBNGHTTP2 1
+_ACEOF
+
+ LIBS="-lnghttp2 $LIBS"
+
+else
+ as_fn_error $? "nghttp2 not found" "$LINENO" 5
+fi
+
+
+elif test $pkg_failed = untried; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+$as_echo "no" >&6; }
+
+ for ac_header in nghttp2.h
+do :
+ ac_fn_c_check_header_mongrel "$LINENO" "nghttp2.h" "ac_cv_header_nghttp2_h" "$ac_includes_default"
+if test "x$ac_cv_header_nghttp2_h" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_NGHTTP2_H 1
+_ACEOF
+
+else
+ as_fn_error $? "nghttp2 headers not found" "$LINENO" 5
+fi
+
+done
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for nghttp2_session in -lnghttp2" >&5
+$as_echo_n "checking for nghttp2_session in -lnghttp2... " >&6; }
+if ${ac_cv_lib_nghttp2_nghttp2_session+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+ ac_check_lib_save_LIBS=$LIBS
+LIBS="-lnghttp2 $LIBS"
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+/* Override any GCC internal prototype to avoid an error.
+ Use char because int might match the return type of a GCC
+ builtin and then its argument prototype would still apply. */
+#ifdef __cplusplus
+extern "C"
+#endif
+char nghttp2_session ();
+int
+main ()
+{
+return nghttp2_session ();
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_link "$LINENO"; then :
+ ac_cv_lib_nghttp2_nghttp2_session=yes
+else
+ ac_cv_lib_nghttp2_nghttp2_session=no
+fi
+rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+LIBS=$ac_check_lib_save_LIBS
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_nghttp2_nghttp2_session" >&5
+$as_echo "$ac_cv_lib_nghttp2_nghttp2_session" >&6; }
+if test "x$ac_cv_lib_nghttp2_nghttp2_session" = xyes; then :
+ cat >>confdefs.h <<_ACEOF
+#define HAVE_LIBNGHTTP2 1
+_ACEOF
+
+ LIBS="-lnghttp2 $LIBS"
+
+else
+ as_fn_error $? "nghttp2 not found" "$LINENO" 5
+fi
+
+
+else
+ libnghttp2_CFLAGS=$pkg_cv_libnghttp2_CFLAGS
+ libnghttp2_LIBS=$pkg_cv_libnghttp2_LIBS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+$as_echo "yes" >&6; }
+
+ as_fn_append CFLAGS " $nghttp2_CFLAGS"
+ as_fn_append LIBS " $nghttp2_LIBS"
+
+fi
+
# Output Makefiles
ac_config_files="$ac_config_files Makefile src/Makefile src/test/Makefile"
@@ -14202,7 +14410,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by dnsperf $as_me 2.6.0, which was
+This file was extended by dnsperf $as_me 2.7.0, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -14269,7 +14477,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-dnsperf config.status 2.6.0
+dnsperf config.status 2.7.0
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"