summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..950156b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@}
+
+execute_after_dh_auto_install:
+ # queryparse
+ cp contrib/queryparse/queryparse debian/dnsperf/usr/bin/pcap-queryparse
+ cp contrib/queryparse/queryparse.1 debian/dnsperf/usr/share/man/man1/pcap-queryparse.1
+ cp contrib/queryparse/USAGE debian/dnsperf/usr/share/doc/dnsperf/pcap-queryparse.USAGE
+
+ # Removing useless files
+ rm -f debian/dnsperf/usr/share/doc/dnsperf/LICENSE
+ rm -f debian/dnsperf/usr/share/doc/dnsperf/README.md