summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-07 17:57:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-07 17:57:46 +0000
commit43bfca11d2f295ff873b2199cf89602bf0e6d843 (patch)
tree029d3f38e63b483f87bca4de62bdce9a42f773a4
parentAdding upstream version 0.3.3. (diff)
downloaddnswire-upstream.tar.xz
dnswire-upstream.zip
Adding upstream version 0.4.0.upstream/0.4.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--.copr/Makefile1
-rw-r--r--CHANGES10
-rw-r--r--configure.ac8
-rw-r--r--rpm/dnswire.spec9
-rw-r--r--src/decoder.c2
-rw-r--r--src/dnstap.c4
-rw-r--r--src/dnswire.c2
-rw-r--r--src/dnswire/decoder.h2
-rw-r--r--src/dnswire/dnstap.h3
-rw-r--r--src/dnswire/dnswire.h2
-rw-r--r--src/dnswire/encoder.h2
-rw-r--r--src/dnswire/reader.h2
-rw-r--r--src/dnswire/trace.h.in2
-rw-r--r--src/dnswire/version.h.in2
-rw-r--r--src/dnswire/writer.h2
-rw-r--r--src/encoder.c2
-rw-r--r--src/reader.c2
-rw-r--r--src/test/test_dnstap.c2
-rw-r--r--src/trace.c2
-rw-r--r--src/writer.c2
20 files changed, 42 insertions, 21 deletions
diff --git a/.copr/Makefile b/.copr/Makefile
index 29ed0bc..919eb2b 100644
--- a/.copr/Makefile
+++ b/.copr/Makefile
@@ -15,6 +15,7 @@ $(top)/rpmbuild:
mkdir -p "$(top)"/rpmbuild/{BUILD,RPMS,SOURCES,SPECS,SRPMS}
srpm: prereq update-dist-tools
+ git config --global safe.directory "*"
test -f .gitmodules && git submodule update --init || true
echo "$(spec)" | grep -q "develop.spec" && auto_build_number=`date --utc +%s` message="Auto build `date --utc --iso-8601=seconds`" "$(top)/dist-tools/spec-new-changelog-entry" || true
overwrite=yes nosign=yes "$(top)/dist-tools/create-source-packages" rpm
diff --git a/CHANGES b/CHANGES
index e4fe8c0..4b56e41 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,13 @@
+2023-03-03 Jerry Lundström
+
+ Release 0.4.0
+
+ Updated `dnstap.pb` to include recently added DNS-over-QUIC (DOQ)
+ socket protocol.
+
+ a03a989 Fix COPR
+ e3f1167 dnstap.pb, DOQ
+
2022-02-02 Jerry Lundström
Release 0.3.3
diff --git a/configure.ac b/configure.ac
index 7d0d9a4..63dc8da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,9 +1,9 @@
AC_PREREQ(2.61)
-AC_INIT([dnswire], [0.3.3], [admin@dns-oarc.net], [dnswire], [https://github.com/DNS-OARC/dnswire/issues])
+AC_INIT([dnswire], [0.4.0], [admin@dns-oarc.net], [dnswire], [https://github.com/DNS-OARC/dnswire/issues])
AC_SUBST([DNSWIRE_VERSION_MAJOR], [0000])
-AC_SUBST([DNSWIRE_VERSION_MINOR], [0003])
-AC_SUBST([DNSWIRE_VERSION_PATCH], [0003])
-AC_SUBST([DNSWIRE_LIBRARY_VERSION], [1:0:0])
+AC_SUBST([DNSWIRE_VERSION_MINOR], [0004])
+AC_SUBST([DNSWIRE_VERSION_PATCH], [0000])
+AC_SUBST([DNSWIRE_LIBRARY_VERSION], [1:1:0])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AC_CONFIG_SRCDIR([src/dnstap.c])
AC_CONFIG_HEADER([src/config.h])
diff --git a/rpm/dnswire.spec b/rpm/dnswire.spec
index b79bfc5..d9edf3b 100644
--- a/rpm/dnswire.spec
+++ b/rpm/dnswire.spec
@@ -1,7 +1,7 @@
%define sover 1
%define libname libdnswire%{sover}
Name: dnswire
-Version: 0.3.3
+Version: 0.4.0
Release: 1%{?dist}
Summary: library for DNS encapsulations and transporting of them
Group: Development/Libraries/C and C++
@@ -97,6 +97,13 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Fri Mar 03 2023 Jerry Lundström <lundstrom.jerry@gmail.com> 0.4.0-1
+- Release 0.4.0
+ * Updated `dnstap.pb` to include recently added DNS-over-QUIC (DOQ)
+ socket protocol.
+ * Commits:
+ a03a989 Fix COPR
+ e3f1167 dnstap.pb, DOQ
* Wed Feb 02 2022 Jerry Lundström <lundstrom.jerry@gmail.com> 0.3.3-1
- Release 0.3.3
* This is a package only update release to correct mistakes in Debian/
diff --git a/src/decoder.c b/src/decoder.c
index 821b14e..d13b015 100644
--- a/src/decoder.c
+++ b/src/decoder.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnstap.c b/src/dnstap.c
index 4e49e64..83d5c0f 100644
--- a/src/dnstap.c
+++ b/src/dnstap.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
@@ -57,6 +57,7 @@ const char* const DNSTAP_SOCKET_PROTOCOL_STRING[] = {
"DOH",
"DNSCryptUDP",
"DNSCryptTCP",
+ "DOQ",
};
const char* const DNSTAP_POLICY_ACTION_STRING[] = {
"UNKNOWN",
@@ -143,6 +144,7 @@ int dnstap_decode_protobuf(struct dnstap* dnstap, const uint8_t* data, size_t le
case DNSTAP_SOCKET_PROTOCOL_DOH:
case DNSTAP_SOCKET_PROTOCOL_DNSCryptUDP:
case DNSTAP_SOCKET_PROTOCOL_DNSCryptTCP:
+ case DNSTAP_SOCKET_PROTOCOL_DOQ:
break;
default:
dnstap->message.has_socket_protocol = false;
diff --git a/src/dnswire.c b/src/dnswire.c
index 5468434..0056a58 100644
--- a/src/dnswire.c
+++ b/src/dnswire.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/decoder.h b/src/dnswire/decoder.h
index 60ab44e..99db44c 100644
--- a/src/dnswire/decoder.h
+++ b/src/dnswire/decoder.h
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/dnstap.h b/src/dnswire/dnstap.h
index 7a01898..dc507ab 100644
--- a/src/dnswire/dnstap.h
+++ b/src/dnswire/dnstap.h
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
@@ -72,6 +72,7 @@ enum dnstap_socket_protocol {
DNSTAP_SOCKET_PROTOCOL_DOH = 4,
DNSTAP_SOCKET_PROTOCOL_DNSCryptUDP = 5,
DNSTAP_SOCKET_PROTOCOL_DNSCryptTCP = 6,
+ DNSTAP_SOCKET_PROTOCOL_DOQ = 7,
};
extern const char* const DNSTAP_SOCKET_PROTOCOL_STRING[];
diff --git a/src/dnswire/dnswire.h b/src/dnswire/dnswire.h
index f113b22..50276c9 100644
--- a/src/dnswire/dnswire.h
+++ b/src/dnswire/dnswire.h
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/encoder.h b/src/dnswire/encoder.h
index c5fbc6a..c635dfb 100644
--- a/src/dnswire/encoder.h
+++ b/src/dnswire/encoder.h
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/reader.h b/src/dnswire/reader.h
index 5fdfad5..55e5f36 100644
--- a/src/dnswire/reader.h
+++ b/src/dnswire/reader.h
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/trace.h.in b/src/dnswire/trace.h.in
index 7b8e038..b74f466 100644
--- a/src/dnswire/trace.h.in
+++ b/src/dnswire/trace.h.in
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/version.h.in b/src/dnswire/version.h.in
index 1a4f96f..0e603ab 100644
--- a/src/dnswire/version.h.in
+++ b/src/dnswire/version.h.in
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/dnswire/writer.h b/src/dnswire/writer.h
index 99bae1a..d989377 100644
--- a/src/dnswire/writer.h
+++ b/src/dnswire/writer.h
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/encoder.c b/src/encoder.c
index 4b7ad27..9825208 100644
--- a/src/encoder.c
+++ b/src/encoder.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/reader.c b/src/reader.c
index ba04284..6710b9b 100644
--- a/src/reader.c
+++ b/src/reader.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/test/test_dnstap.c b/src/test/test_dnstap.c
index eec0049..2a36a81 100644
--- a/src/test/test_dnstap.c
+++ b/src/test/test_dnstap.c
@@ -47,7 +47,7 @@ int main(void)
d.message.socket_family = (enum _Dnstap__SocketFamily)DNSTAP_SOCKET_FAMILY_INET;
// invalid message.socket_protocol
- d.message.socket_protocol = (enum _Dnstap__SocketProtocol)(DNSTAP_SOCKET_PROTOCOL_DNSCryptTCP + 1);
+ d.message.socket_protocol = (enum _Dnstap__SocketProtocol)(DNSTAP_SOCKET_PROTOCOL_DOQ + 1);
s = dnstap_encode_protobuf_size(&d);
assert(s < sizeof(buf));
assert(dnstap_encode_protobuf(&d, buf) == s);
diff --git a/src/trace.c b/src/trace.c
index 742f819..19b3ddf 100644
--- a/src/trace.c
+++ b/src/trace.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.
diff --git a/src/writer.c b/src/writer.c
index 885ff91..f65606b 100644
--- a/src/writer.c
+++ b/src/writer.c
@@ -1,6 +1,6 @@
/*
* Author Jerry Lundström <jerry@dns-oarc.net>
- * Copyright (c) 2019, OARC, Inc.
+ * Copyright (c) 2019-2023, OARC, Inc.
* All rights reserved.
*
* This file is part of the dnswire library.