summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1015993
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh ${@}
+
+execute_after_dh_auto_clean:
+ rm -f src/dnstap.pb
+
+execute_after_dh_auto_configure:
+ ln -s /usr/share/gocode/src/github.com/dnstap/golang-dnstap/dnstap.pb src/dnstap.pb
+
+execute_after_dh_auto_install:
+ # removing unused files
+ rm -f debian/tmp/usr/lib/*/*.la
+ rm -f debian/tmp/usr/share/doc/*/README.md