summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-09-04 08:54:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-09-04 08:54:34 +0000
commit1b1696fac3d59300de1814078ab3ee7581578e51 (patch)
treea461a62aa5e390641772de0fff12349b73e55ea6 /pyproject.toml
parentReleasing debian version 0.8.1-3. (diff)
downloadeos-downloader-1b1696fac3d59300de1814078ab3ee7581578e51.tar.xz
eos-downloader-1b1696fac3d59300de1814078ab3ee7581578e51.zip
Merging upstream version 0.8.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml124
1 files changed, 72 insertions, 52 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2b510e3..1fa01f9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "eos_downloader"
-version = "v0.8.1-dev1"
+version = "v0.8.2"
readme = "README.md"
authors = [{ name = "Thomas Grimonet", email = "thomas.grimonet@gmail.com" }]
maintainers = [
@@ -15,61 +15,62 @@ maintainers = [
description = "Arista EOS/CVP downloader script"
license = { file = "LICENSE" }
dependencies = [
-"cryptography",
-"paramiko",
-"requests>=2.20.0",
-"requests-toolbelt",
-"scp",
-"tqdm",
-"loguru",
-"rich==12.0.1",
-"cvprac>=1.0.7",
-"click==8.1.3",
-"click-help-colors==0.9.1",
-"pydantic==1.10.4",
+ "cryptography",
+ "paramiko",
+ "requests>=2.20.0",
+ "requests-toolbelt",
+ "scp",
+ "tqdm",
+ "loguru",
+ "rich~=13.5.2",
+ "cvprac>=1.0.7",
+ "click~=8.1.6",
+ "click-help-colors~=0.9",
+ "pydantic>2.0.0,<3.0.0",
]
keywords = ["eos_downloader", "Arista", "eos", "cvp", "network", "automation", "networking", "devops", "netdevops"]
classifiers = [
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'Intended Audience :: System Administrators',
- 'Intended Audience :: Information Technology',
- 'Topic :: System :: Software Distribution',
- 'Topic :: Terminals',
- 'Topic :: Utilities',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Programming Language :: Python :: 3 :: Only',
- 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'Intended Audience :: Information Technology',
+ 'Topic :: System :: Software Distribution',
+ 'Topic :: Terminals',
+ 'Topic :: Utilities',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: Implementation :: PyPy',
]
requires-python = ">=3.8"
[project.optional-dependencies]
dev = [
-"isort==5.12.0",
-"mypy==0.991",
-"mypy-extensions>=0.4.3",
-"pre-commit>=2.20.0",
-"pylint",
-"pytest>=7.1.2",
-"pytest-cov>=2.11.1",
-"pytest-dependency",
-"pytest-html>=3.1.1",
-"pytest-metadata>=1.11.0",
-"pylint-pydantic>=0.1.4",
-"tox==4.0.11",
-"types-PyYAML",
-"types-paramiko",
-"types-requests",
-"typing-extensions",
-"yamllint",
-"flake8==4.0.1",
-"pyflakes==2.4.0"
+ "isort==5.12.0",
+ "mypy==1.5.1",
+ "mypy-extensions>=0.4.3",
+ "pre-commit>=2.20.0",
+ "pylint",
+ "pytest>=7.1.2",
+ "pytest-cov>=2.11.1",
+ "pytest-dependency",
+ "pytest-html>=3.1.1",
+ "pytest-metadata>=1.11.0",
+ "pylint-pydantic>=0.2.4",
+ "tox==4.10.0",
+ "types-PyYAML",
+ "types-paramiko",
+ "types-requests",
+ "typing-extensions",
+ "yamllint",
+ "flake8>=4.0.1",
+ "pyflakes>=2.4.0",
+ "bumpver>=2023.1126"
]
[project.urls]
@@ -81,10 +82,29 @@ Contributing = "https://www.github.com/titom73/eos-downloader"
ardl = "eos_downloader.cli.cli:cli"
lard = "eos_downloader.cli.cli:cli"
+################################
+# Tools
+################################
+
[tool.setuptools.packages.find]
include = ["eos_downloader*"]
namespaces = false
+################################
+# Version
+################################
+[tool.bumpver]
+current_version = "0.8.2"
+version_pattern = "MAJOR.MINOR.PATCH"
+commit_message = "bump: Version {old_version} -> {new_version}"
+commit = true
+# No tag
+tag = false
+push = false
+
+[tool.bumpver.file_patterns]
+"pyproject.toml" = ['current_version = "{version}"', 'version = "v{version}"']
+
# mypy as per https://pydantic-docs.helpmanual.io/mypy_plugin/#enabling-the-plugin
[tool.mypy]
plugins = [
@@ -120,8 +140,8 @@ min_version = 4.0
envlist =
clean,
lint,
- type
-
+ type,
+ py{38,39,310}
[tox-full]
min_version = 4.0
@@ -132,13 +152,13 @@ envlist =
type,
report
-[gh-actions]
+[gh-actions-base]
python =
3.8: lint, type
3.9: lint, type
3.10: lint, type
-[gh-actions-full]
+[gh-actions]
python =
3.8: py38
3.9: py39