summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-10-10 09:54:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-10-10 09:54:17 +0000
commitb0554023303fe8656173d3dfbd0d2449145df38e (patch)
treedd749f47419b53ca3a5ec7f7bbe2590b8aafc041 /pyproject.toml
parentReleasing debian version 0.8.2-1. (diff)
downloadeos-downloader-b0554023303fe8656173d3dfbd0d2449145df38e.tar.xz
eos-downloader-b0554023303fe8656173d3dfbd0d2449145df38e.zip
Merging upstream version 0.9.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1fa01f9..f98c4ee 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "eos_downloader"
-version = "v0.8.2"
+version = "v0.9.0"
readme = "README.md"
authors = [{ name = "Thomas Grimonet", email = "thomas.grimonet@gmail.com" }]
maintainers = [
@@ -22,7 +22,7 @@ dependencies = [
"scp",
"tqdm",
"loguru",
- "rich~=13.5.2",
+ "rich>=13.5.2,<13.7.0",
"cvprac>=1.0.7",
"click~=8.1.6",
"click-help-colors~=0.9",
@@ -62,7 +62,7 @@ dev = [
"pytest-html>=3.1.1",
"pytest-metadata>=1.11.0",
"pylint-pydantic>=0.2.4",
- "tox==4.10.0",
+ "tox~=4.11",
"types-PyYAML",
"types-paramiko",
"types-requests",
@@ -94,7 +94,7 @@ namespaces = false
# Version
################################
[tool.bumpver]
-current_version = "0.8.2"
+current_version = "0.9.0"
version_pattern = "MAJOR.MINOR.PATCH"
commit_message = "bump: Version {old_version} -> {new_version}"
commit = true