summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 08:23:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 08:23:39 +0000
commitfce0b7f16de0c9fb29edcb923b63cd3b6db05f91 (patch)
tree915d54fc6a6353ffb324b7fd19e8c2e70a341857 /pyproject.toml
parentReleasing debian version 0.9.0-1. (diff)
downloadeos-downloader-fce0b7f16de0c9fb29edcb923b63cd3b6db05f91.tar.xz
eos-downloader-fce0b7f16de0c9fb29edcb923b63cd3b6db05f91.zip
Merging upstream version 0.10.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f98c4ee..f125def 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,7 +6,7 @@ build-backend = "setuptools.build_meta"
[project]
name = "eos_downloader"
-version = "v0.9.0"
+version = "v0.10.0"
readme = "README.md"
authors = [{ name = "Thomas Grimonet", email = "thomas.grimonet@gmail.com" }]
maintainers = [
@@ -22,7 +22,7 @@ dependencies = [
"scp",
"tqdm",
"loguru",
- "rich>=13.5.2,<13.7.0",
+ "rich>=13.5.2,<13.8.0",
"cvprac>=1.0.7",
"click~=8.1.6",
"click-help-colors~=0.9",
@@ -51,8 +51,8 @@ requires-python = ">=3.8"
[project.optional-dependencies]
dev = [
- "isort==5.12.0",
- "mypy==1.5.1",
+ "mypy==1.8.0",
+ "isort==5.13.2",
"mypy-extensions>=0.4.3",
"pre-commit>=2.20.0",
"pylint",
@@ -94,7 +94,7 @@ namespaces = false
# Version
################################
[tool.bumpver]
-current_version = "0.9.0"
+current_version = "0.10.0"
version_pattern = "MAJOR.MINOR.PATCH"
commit_message = "bump: Version {old_version} -> {new_version}"
commit = true