summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..ccbc15c
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+CURRENT_DIR = $(shell pwd)
+
+DOCKER_NAME ?= titom73/eos-downloader
+DOCKER_TAG ?= dev
+DOCKER_FILE ?= Dockerfile
+PYTHON_VER ?= 3.9
+
+.PHONY: build
+build:
+ docker build -t $(DOCKER_NAME):$(DOCKER_TAG) --build-arg DOCKER_VERSION=$(DOCKER_VERSION) -f $(DOCKER_FILE) .