summaryrefslogtreecommitdiffstats
path: root/.devcontainer
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:03:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:03:07 +0000
commitdcc28a9a987457acf9e2c8249a9df5e40143eba3 (patch)
treea3b44db00ff34f0dee0406875e7320c4dce3041e /.devcontainer
parentReleasing debian version 0.19.0~dev-1. (diff)
downloadgitlint-dcc28a9a987457acf9e2c8249a9df5e40143eba3.tar.xz
gitlint-dcc28a9a987457acf9e2c8249a9df5e40143eba3.zip
Merging upstream version 0.19.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.devcontainer')
-rw-r--r--.devcontainer/devcontainer.json11
-rwxr-xr-x.devcontainer/postCreateCommand.sh1
2 files changed, 9 insertions, 3 deletions
diff --git a/.devcontainer/devcontainer.json b/.devcontainer/devcontainer.json
index 5889037..65fcc1c 100644
--- a/.devcontainer/devcontainer.json
+++ b/.devcontainer/devcontainer.json
@@ -22,7 +22,11 @@
"settings": {
"python.defaultInterpreterPath": "/usr/local/bin/python",
"python.linting.enabled": true,
- "python.linting.pylintEnabled": true,
+ "python.formatting.provider": "black",
+ "python.formatting.blackArgs": [
+ "--config",
+ "./pyproject.toml"
+ ],
"python.formatting.autopep8Path": "/usr/local/py-utils/bin/autopep8",
"python.formatting.blackPath": "/usr/local/py-utils/bin/black",
"python.formatting.yapfPath": "/usr/local/py-utils/bin/yapf",
@@ -31,12 +35,13 @@
"python.linting.mypyPath": "/usr/local/py-utils/bin/mypy",
"python.linting.pycodestylePath": "/usr/local/py-utils/bin/pycodestyle",
"python.linting.pydocstylePath": "/usr/local/py-utils/bin/pydocstyle",
- "python.linting.pylintPath": "/usr/local/py-utils/bin/pylint"
},
// Add the IDs of extensions you want installed when the container is created.
"extensions": [
"ms-python.python",
- "ms-python.vscode-pylance"
+ "ms-python.vscode-pylance",
+ "charliermarsh.ruff",
+ "tamasfe.even-better-toml"
]
}
},
diff --git a/.devcontainer/postCreateCommand.sh b/.devcontainer/postCreateCommand.sh
index 4bbaf05..e2f0f76 100755
--- a/.devcontainer/postCreateCommand.sh
+++ b/.devcontainer/postCreateCommand.sh
@@ -1,6 +1,7 @@
#!/bin/sh -x
brew install asdf
+brew install hatch
source "$(brew --prefix asdf)/libexec/asdf.sh"
# Install latest python