summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-19 14:00:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-19 14:00:32 +0000
commite5cbe6d7fe39e950fb61272365ce88f9a3ca7953 (patch)
treebbe28d40cfc9dd88707539a4aad25ecaf9470b4b /debian/patches
parentAdding upstream version 0.13.1. (diff)
downloadgitlint-e5cbe6d7fe39e950fb61272365ce88f9a3ca7953.tar.xz
gitlint-e5cbe6d7fe39e950fb61272365ce88f9a3ca7953.zip
Adding debian version 0.13.1-0.1.debian/0.13.1-0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-replace-readfp-with-Python2-read_file-function-to-fi.patch40
-rw-r--r--debian/patches/series1
2 files changed, 41 insertions, 0 deletions
diff --git a/debian/patches/0001-replace-readfp-with-Python2-read_file-function-to-fi.patch b/debian/patches/0001-replace-readfp-with-Python2-read_file-function-to-fi.patch
new file mode 100644
index 0000000..dde4da9
--- /dev/null
+++ b/debian/patches/0001-replace-readfp-with-Python2-read_file-function-to-fi.patch
@@ -0,0 +1,40 @@
+Forwarded: https://github.com/jorisroovers/gitlint/pull/104
+From 84145c703a25acad5f2378535c642c5abc299fbe Mon Sep 17 00:00:00 2001
+From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+Date: Thu, 26 Sep 2019 10:48:14 +0200
+Subject: [PATCH] replace readfp with Python2 read_file function, to fix a test
+ failure:
+
+======================================================================
+FAIL: test_config_file (test_cli.CLITests)
+Test for --config option
+----------------------------------------------------------------------
+Traceback (most recent call last):
+ File "/usr/lib/python3.7/unittest/mock.py", line 1248, in patched
+ return func(*args, **keywargs)
+ File "/<<PKGBUILDDIR>>/gitlint/tests/test_cli.py", line 372, in test_config_file
+ self.assertEqual(result.output, "")
+AssertionError: "/<<PKGBUILDDIR>>/git[197 chars]od\n" != ''
+- /<<PKGBUILDDIR>>/gitlint/config.py:366: DeprecationWarning: This method will be removed in future versions. Use 'parser.read_file()' instead.
+- parser.readfp(config_file, filename) # pylint: disable=deprecated-method
+---
+ gitlint/config.py | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/gitlint/config.py b/gitlint/config.py
+index fdc5e85..654523d 100644
+--- a/gitlint/config.py
++++ b/gitlint/config.py
+@@ -428,8 +428,7 @@ class LintConfigBuilder(object):
+ parser = ConfigParser()
+
+ with io.open(filename, encoding=DEFAULT_ENCODING) as config_file:
+- # readfp() is deprecated in python 3.2+, but compatible with 2.7
+- parser.readfp(config_file, filename) # pylint: disable=deprecated-method
++ parser.read_file(config_file)
+
+ for section_name in parser.sections():
+ for option_name, option_value in parser.items(section_name):
+--
+2.17.1
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..3fede26
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-replace-readfp-with-Python2-read_file-function-to-fi.patch