summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-19 14:06:51 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-19 14:06:51 +0000
commit1fce8684a10fd08fb4d6bf71294c5516fb3c5c7a (patch)
tree2d2c07c7bc250a186590f1be15690a9609ec8b7c /debian/rules
parentSorting dh arguments in rules. (diff)
downloadgitlint-1fce8684a10fd08fb4d6bf71294c5516fb3c5c7a.tar.xz
gitlint-1fce8684a10fd08fb4d6bf71294c5516fb3c5c7a.zip
Using execute_after targets in rules to be explicit what we're doing.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 3c40bc7..8ba7386 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,8 +9,9 @@ export PYBUILD_TEST_ARGS=python{version} -m coverage run --omit='/usr/*,$(CURDIR
override_dh_auto_test:
PYBUILD_SYSTEM=custom dh_auto_test
-override_dh_install:
- dh_install
+execute_after_dh_auto_install:
# we don't want them in the package?
rm -rf debian/gitlint/usr/lib/python*/dist-packages/qa
+
+execute_after_dh_fixperms:
find debian/gitlint/usr/lib -name commit-msg -exec chmod +x {} \;