summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-19 14:00:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-19 14:00:32 +0000
commite5cbe6d7fe39e950fb61272365ce88f9a3ca7953 (patch)
treebbe28d40cfc9dd88707539a4aad25ecaf9470b4b /debian/rules
parentAdding upstream version 0.13.1. (diff)
downloadgitlint-e5cbe6d7fe39e950fb61272365ce88f9a3ca7953.tar.xz
gitlint-e5cbe6d7fe39e950fb61272365ce88f9a3ca7953.zip
Adding debian version 0.13.1-0.1.debian/0.13.1-0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a26ed64
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+export LC_ALL=C.UTF-8
+export PYBUILD_TEST_ARGS=python{version} -m coverage run --omit='/usr/*,$(CURDIR)/gitlint/tests/*,$(CURDIR)/gitlint/qa/*' -m unittest discover -v -s $(CURDIR)/gitlint/tests
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_test:
+ PYBUILD_SYSTEM=custom dh_auto_test
+
+override_dh_install:
+ dh_install
+ # we don't want them in the package?
+ rm -rf debian/gitlint/usr/lib/python*/dist-packages/qa
+ find debian/gitlint/usr/lib -name commit-msg -exec chmod +x {} \;