summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-01-25 13:26:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-01-25 13:26:35 +0000
commit4fee3e091a8d79a40f70ff9c1f87b29b9340049a (patch)
tree465ad9629a8ee56548bd6c51c3fc710907564911 /setup.py
parentReleasing debian version 0.14.0-1. (diff)
downloadgitlint-4fee3e091a8d79a40f70ff9c1f87b29b9340049a.tar.xz
gitlint-4fee3e091a8d79a40f70ff9c1f87b29b9340049a.zip
Merging upstream version 0.15.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 10 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 1e9f35a..3220f82 100644
--- a/setup.py
+++ b/setup.py
@@ -7,13 +7,6 @@ import os
import platform
import sys
-# There is an issue with building python packages in a shared vagrant directory because of how setuptools works
-# in python < 2.7.9. We solve this by deleting the filesystem hardlinking capability during build.
-# See: http://stackoverflow.com/a/22147112/381010
-try:
- del os.link
-except:
- pass # Not all OSes (e.g. windows) support os.link
description = "Git commit message linter written in python, checks your commit messages for style."
long_description = """
@@ -52,8 +45,6 @@ setup(
"Development Status :: 5 - Production/Stable",
"Operating System :: OS Independent",
"Programming Language :: Python",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
@@ -66,18 +57,23 @@ setup(
"Topic :: Software Development :: Testing",
"License :: OSI Approved :: MIT License"
],
+ python_requires=">=3.6",
install_requires=[
- 'Click==7.0',
- 'arrow==0.15.5',
+ 'Click==7.1.2',
+ 'arrow==0.17.0',
],
extras_require={
':sys_platform != "win32"': [
- 'sh==1.12.14',
+ 'sh==1.14.1',
],
},
keywords='gitlint git lint',
author='Joris Roovers',
- url='https://github.com/jorisroovers/gitlint',
+ url='https://jorisroovers.github.io/gitlint',
+ project_urls={
+ 'Documentation': 'https://jorisroovers.github.io/gitlint',
+ 'Source': 'https://github.com/jorisroovers/gitlint',
+ },
license='MIT',
package_data={
'gitlint': ['files/*']
@@ -93,8 +89,7 @@ setup(
# Print a red deprecation warning for python < 3.6 users
if sys.version_info[:2] < (3, 6):
msg = "\033[31mDEPRECATION: You're using a python version that has reached end-of-life. " + \
- "Gitlint does not support Python < 3.5 or < 2.7, and will be dropping support for " + \
- "Python 2.7 and 3.5 in the next release. " + \
+ "Gitlint does not support Python < 3.6" + \
"Please upgrade your Python to 3.6 or above.\033[0m"
print(msg)