summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-19 14:52:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-19 14:53:01 +0000
commitf3b6c222fb11c96e2f8bbaa0622f46c8ec486874 (patch)
tree0f38497775e27d3e16b20573b36dd22aa5b24f3e /setup.py
parentReleasing debian version 0.17.0-1. (diff)
downloadgitlint-f3b6c222fb11c96e2f8bbaa0622f46c8ec486874.tar.xz
gitlint-f3b6c222fb11c96e2f8bbaa0622f46c8ec486874.zip
Merging upstream version 0.18.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 11 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index aa800fd..21b3c42 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ Source code on `github.com/jorisroovers/gitlint`_.
"""
-version = "0.17.0"
+version = "0.18.0"
setup(
name="gitlint",
@@ -39,24 +39,26 @@ setup(
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Environment :: Console",
"Intended Audience :: Developers",
"Topic :: Software Development :: Quality Assurance",
"Topic :: Software Development :: Testing",
- "License :: OSI Approved :: MIT License"
+ "License :: OSI Approved :: MIT License",
],
python_requires=">=3.6",
install_requires=[
- 'gitlint-core[trusted-deps]==' + version,
+ "gitlint-core[trusted-deps]==" + version,
],
- keywords='gitlint git lint',
- author='Joris Roovers',
- url='https://jorisroovers.github.io/gitlint',
+ keywords="gitlint git lint",
+ author="Joris Roovers",
+ url="https://jorisroovers.github.io/gitlint",
project_urls={
- 'Documentation': 'https://jorisroovers.github.io/gitlint',
- 'Source': 'https://github.com/jorisroovers/gitlint',
+ "Documentation": "https://jorisroovers.github.io/gitlint",
+ "Source": "https://github.com/jorisroovers/gitlint",
+ "Changelog": "https://github.com/jorisroovers/gitlint/blob/main/CHANGELOG.md",
},
- license='MIT',
+ license="MIT",
)