summaryrefslogtreecommitdiffstats
path: root/.devcontainer/devcontainer.json
diff options
context:
space:
mode:
Diffstat (limited to '.devcontainer/devcontainer.json')
-rw-r--r--.devcontainer/devcontainer.json11
1 files changed, 8 insertions, 3 deletions
diff --git a/.devcontainer/devcontainer.json b/.devcontainer/devcontainer.json
index 5889037..65fcc1c 100644
--- a/.devcontainer/devcontainer.json
+++ b/.devcontainer/devcontainer.json
@@ -22,7 +22,11 @@
"settings": {
"python.defaultInterpreterPath": "/usr/local/bin/python",
"python.linting.enabled": true,
- "python.linting.pylintEnabled": true,
+ "python.formatting.provider": "black",
+ "python.formatting.blackArgs": [
+ "--config",
+ "./pyproject.toml"
+ ],
"python.formatting.autopep8Path": "/usr/local/py-utils/bin/autopep8",
"python.formatting.blackPath": "/usr/local/py-utils/bin/black",
"python.formatting.yapfPath": "/usr/local/py-utils/bin/yapf",
@@ -31,12 +35,13 @@
"python.linting.mypyPath": "/usr/local/py-utils/bin/mypy",
"python.linting.pycodestylePath": "/usr/local/py-utils/bin/pycodestyle",
"python.linting.pydocstylePath": "/usr/local/py-utils/bin/pydocstyle",
- "python.linting.pylintPath": "/usr/local/py-utils/bin/pylint"
},
// Add the IDs of extensions you want installed when the container is created.
"extensions": [
"ms-python.python",
- "ms-python.vscode-pylance"
+ "ms-python.vscode-pylance",
+ "charliermarsh.ruff",
+ "tamasfe.even-better-toml"
]
}
},