summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 12 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 50d8599..3df7be3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,18 @@
#!/usr/bin/make -f
-export LC_ALL=C.UTF-8
-export PYBUILD_TEST_ARGS=python{version} -m coverage run --omit='/usr/*,$(CURDIR)/gitlint/tests/*,$(CURDIR)/gitlint/qa/*' -m unittest discover -v -s $(CURDIR)/gitlint/tests
+VERSION := $(shell dpkg-parsechangelog -SVersion)
%:
- dh ${@} --buildsystem=pybuild --with python3
+ dh ${@} --buildsystem=pybuild --sourcedir=$(CURDIR)/gitlint-core
+
+execute_after_dh_auto_clean:
+ rm -f gitlint-core/_version.py
+
+execute_before_dh_auto_build:
+ echo "__version__ = version = '$(VERSION)'" > gitlint-core/_version.py
override_dh_auto_test:
- PYBUILD_SYSTEM=custom dh_auto_test
+ # disabled
execute_after_dh_auto_install:
# manpage
@@ -22,3 +27,6 @@ execute_after_dh_auto_install:
execute_after_dh_fixperms:
find debian/gitlint/usr/lib -name commit-msg -exec chmod +x {} \;
+
+override_dh_missing:
+ # disabled