summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 13:44:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 14:43:57 +0000
commit5881221fc546619da24dfc5acb1d4c1168234a5f (patch)
tree216a593a4036ab60d46581e082469659fe9bf96f
parentMoving patches to version gnome-shell version specific directory. (diff)
downloadgnome-shell-extensions-extra-5881221fc546619da24dfc5acb1d4c1168234a5f.tar.xz
gnome-shell-extensions-extra-5881221fc546619da24dfc5acb1d4c1168234a5f.zip
Updating rules to build for gnome-shell version 43.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules19
2 files changed, 19 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index ec69ee9..3271bc7 100644
--- a/debian/control
+++ b/debian/control
@@ -18,8 +18,8 @@ Package: gnome-shell-extensions-extra
Section: gnome
Architecture: all
Depends:
- gnome-shell (>= 43~),
- gnome-shell (<< 45~),
+ gnome-shell (>= ${gnome-shell:Depends:low}~),
+ gnome-shell (<< ${gnome-shell:Depends:high}~),
${misc:Depends},
Recommends:
gnome-tweaks,
diff --git a/debian/rules b/debian/rules
index e71b69c..f3692b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,29 @@
#!/usr/bin/make -f
+EXTENSIONS_VERSION = 44
+
+GNOME_SHELL_DEPENDS_LOW = 43
+GNOME_SHELL_DEPENDS_HIGH = 45
+
%:
dh ${@} --no-parallel
execute_after_dh_auto_clean:
+ rm -f extensions/current
+
# remove generated files
- rm -f extensions/*/*/schemas/gschemas.compiled
- rm -f extensions/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+ rm -f extensions/44/*/*/schemas/gschemas.compiled
+ rm -f extensions/44/middleclickclose/*/locale/*/LC_MESSAGES/*.mo
+
+execute_before_dh_auto_build:
+ ln -s $(EXTENSIONS_VERSION) extensions/current
execute_after_dh_auto_install:
# removing unused files
rm -f debian/gnome-shell-extensions-extra/usr/share/doc/*/CHANGELOG.txt
rm -f debian/gnome-shell-extensions-extra/usr/share/doc/*/LICENSE.txt
+
+override_dh_gencontrol:
+ dh_gencontrol -- \
+ -Vgnome-shell:Depends:low="$(GNOME_SHELL_DEPENDS_LOW)" \
+ -Vgnome-shell:Depends:high="$(GNOME_SHELL_DEPENDS_HIGH)"