summaryrefslogtreecommitdiffstats
path: root/extensions/middleclickclose.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 14:37:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-10 14:43:55 +0000
commit202aca7bf4eb4927658b82b627afb9dab254a551 (patch)
tree2be0e541d4ce5b6d2a517daa37151bd0d8ba948e /extensions/middleclickclose.mk
parentReleasing debian version 20230618-3. (diff)
downloadgnome-shell-extensions-extra-202aca7bf4eb4927658b82b627afb9dab254a551.tar.xz
gnome-shell-extensions-extra-202aca7bf4eb4927658b82b627afb9dab254a551.zip
Merging upstream version 20231210.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'extensions/middleclickclose.mk')
-rw-r--r--extensions/middleclickclose.mk57
1 files changed, 0 insertions, 57 deletions
diff --git a/extensions/middleclickclose.mk b/extensions/middleclickclose.mk
deleted file mode 100644
index d484427..0000000
--- a/extensions/middleclickclose.mk
+++ /dev/null
@@ -1,57 +0,0 @@
-# Progress Linux: gnome-shell-extensions-extra
-
-# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
-#
-# SPDX-License-Identifier: GPL-3.0+
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <https://www.gnu.org/licenses/>.
-
-# Build-Depends:
-# gettext libglib2.0-bin
-
-SHELL := sh -e
-
-EXTENSION := middleclickclose
-UUID := $(shell awk -F\" '/"uuid": / { print $$4 }' $(EXTENSION)/*@*/metadata.json)
-
-all:
-
-test:
-
-build:
- for TRANSLATION in $(EXTENSION)/$(UUID)/locale/*/*/*.mo; \
- do \
- msgfmt -cv -o $${TRANSLATION} $$(dirname $${TRANSLATION})/$$(basename $${TRANSLATION} .mo).po; \
- done
-
- glib-compile-schemas --strict --targetdir=$(EXTENSION)/$(UUID)/schemas/ $(EXTENSION)/$(UUID)/schemas
-
-install: build
- mkdir -p $(DESTDIR)/usr/share/gnome-shell/extensions
- cp -a $(EXTENSION)/$(UUID) $(DESTDIR)/usr/share/gnome-shell/extensions
-
-uninstall:
- rm -rf $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)
- rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
-
-clean:
-
-distclean:
-
-reinstall: uninstall install
-
-upstream:
- rm -rf $(EXTENSION)
- git clone https://github.com/p91paul/$(EXTENSION)
- rm -rf $(EXTENSION)/.git