summaryrefslogtreecommitdiffstats
path: root/extensions/multi-monitors-add-on.mk
diff options
context:
space:
mode:
Diffstat (limited to 'extensions/multi-monitors-add-on.mk')
-rw-r--r--extensions/multi-monitors-add-on.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/extensions/multi-monitors-add-on.mk b/extensions/multi-monitors-add-on.mk
new file mode 100644
index 0000000..e3658ff
--- /dev/null
+++ b/extensions/multi-monitors-add-on.mk
@@ -0,0 +1,57 @@
+# Progress Linux: gnome-shell-extensions-extra
+
+# Copyright (C) 2010-2023 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Build-Depends:
+# gettext libglib2.0-bin
+
+SHELL := sh -e
+
+EXTENSION := multi-monitors-add-on
+UUID := $(shell awk -F\" '/"uuid": / { print $$4 }' $(EXTENSION)/*@*/metadata.json)
+
+all:
+
+test:
+
+build:
+ for TRANSLATION in $(EXTENSION)/$(UUID)/locale/*; \
+ do \
+ msgfmt -cv -o $${TRANSLATION}/LC_MESSAGES/$(EXTENSION).mo $${TRANSLATION}/LC_MESSAGES/$(EXTENSION).po; \
+ done
+
+ glib-compile-schemas --strict --targetdir=$(EXTENSION)/$(UUID)/schemas/ $(EXTENSION)/$(UUID)/schemas
+
+install: build
+ mkdir -p $(DESTDIR)/usr/share/gnome-shell/extensions
+ cp -a $(EXTENSION)/$(UUID) $(DESTDIR)/usr/share/gnome-shell/extensions
+
+uninstall:
+ rm -rf $(DESTDIR)/usr/share/gnome-shell/extensions/$(UUID)
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+
+distclean:
+
+reinstall: uninstall install
+
+upstream:
+ rm -rf $(EXTENSION)
+ git clone https://github.com/realh/$(EXTENSION)
+ rm -rf $(EXTENSION)/.git