summaryrefslogtreecommitdiffstats
path: root/.coveragerc
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-24 23:10:43 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-24 23:10:43 +0000
commit4bbf6c088551d74da917b0ad9c1e83366afa9a50 (patch)
treee50dbe6b1d31c17ef7129d50c6bc5480c5539690 /.coveragerc
parentInitial commit. (diff)
downloadidentify-4bbf6c088551d74da917b0ad9c1e83366afa9a50.tar.xz
identify-4bbf6c088551d74da917b0ad9c1e83366afa9a50.zip
Adding upstream version 1.4.13.upstream/1.4.13
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.coveragerc')
-rw-r--r--.coveragerc29
1 files changed, 29 insertions, 0 deletions
diff --git a/.coveragerc b/.coveragerc
new file mode 100644
index 0000000..f995964
--- /dev/null
+++ b/.coveragerc
@@ -0,0 +1,29 @@
+[run]
+branch = True
+source =
+ .
+omit =
+ .tox/*
+ /usr/*
+ setup.py
+
+[report]
+show_missing = True
+
+exclude_lines =
+ # Have to re-enable the standard pragma
+ \#\s*pragma: no cover
+
+ # Don't complain if tests don't hit defensive assertion code:
+ ^\s*raise AssertionError\b
+ ^\s*raise NotImplementedError\b
+ ^\s*return NotImplemented\b
+ ^\s*raise$
+
+ # Don't complain if non-runnable code isn't run:
+ ^if __name__ == ['"]__main__['"]:$
+
+[html]
+directory = coverage-html
+
+# vim:ft=dosini