summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-09-04 09:23:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-09-04 09:23:56 +0000
commit39032ea2df298de1b3816a094fbed1623eb93506 (patch)
tree6a23d72eba0c8e56d83384854a8f54a7779bcd1f
parentReleasing debian version 2.5.26-2. (diff)
downloadidentify-39032ea2df298de1b3816a094fbed1623eb93506.tar.xz
identify-39032ea2df298de1b3816a094fbed1623eb93506.zip
Merging upstream version 2.5.27.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--.pre-commit-config.yaml8
-rw-r--r--identify/extensions.py3
-rw-r--r--setup.cfg2
-rw-r--r--tests/identify_test.py1
4 files changed, 8 insertions, 6 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 3fa68df..93b245a 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -19,11 +19,11 @@ repos:
- id: reorder-python-imports
args: [--py38-plus, --add-import, 'from __future__ import annotations']
- repo: https://github.com/asottile/add-trailing-comma
- rev: v3.0.0
+ rev: v3.0.1
hooks:
- id: add-trailing-comma
- repo: https://github.com/asottile/pyupgrade
- rev: v3.9.0
+ rev: v3.10.1
hooks:
- id: pyupgrade
args: [--py38-plus]
@@ -32,11 +32,11 @@ repos:
hooks:
- id: autopep8
- repo: https://github.com/PyCQA/flake8
- rev: 6.0.0
+ rev: 6.1.0
hooks:
- id: flake8
exclude: ^identify/vendor/licenses\.py$
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v1.4.1
+ rev: v1.5.0
hooks:
- id: mypy
diff --git a/identify/extensions.py b/identify/extensions.py
index a9e0d6a..4202ada 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -10,6 +10,7 @@ EXTENSIONS = {
'bash': {'text', 'shell', 'bash'},
'bat': {'text', 'batch'},
'bats': {'text', 'shell', 'bash', 'bats'},
+ 'bazel': {'text', 'bazel'},
'beancount': {'text', 'beancount'},
'bib': {'text', 'bib'},
'bmp': {'binary', 'image', 'bitmap'},
@@ -326,10 +327,10 @@ NAMES = {
'.zshenv': EXTENSIONS['zsh'],
'AUTHORS': EXTENSIONS['txt'],
'BUILD': EXTENSIONS['bzl'],
- 'BUILD.bazel': EXTENSIONS['bzl'],
'CMakeLists.txt': EXTENSIONS['cmake'],
'CHANGELOG': EXTENSIONS['txt'],
'config.ru': EXTENSIONS['rb'],
+ 'Containerfile': {'text', 'dockerfile'},
'CONTRIBUTING': EXTENSIONS['txt'],
'COPYING': EXTENSIONS['txt'],
'Dockerfile': {'text', 'dockerfile'},
diff --git a/setup.cfg b/setup.cfg
index 28a5a0e..31fdaa2 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 2.5.26
+version = 2.5.27
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown
diff --git a/tests/identify_test.py b/tests/identify_test.py
index 3429c12..ac458df 100644
--- a/tests/identify_test.py
+++ b/tests/identify_test.py
@@ -154,6 +154,7 @@ def test_tags_from_path_plist_text(tmpdir):
('test.py', {'text', 'python'}),
('test.mk', {'text', 'makefile'}),
('Makefile', {'text', 'makefile'}),
+ ('Containerfile', {'text', 'dockerfile'}),
('Dockerfile', {'text', 'dockerfile'}),
('Dockerfile.xenial', {'text', 'dockerfile'}),
('xenial.Dockerfile', {'text', 'dockerfile'}),