summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-30 16:51:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-30 16:51:22 +0000
commit4604e340e95ecd8d432e257f4594bb5a3752f9d5 (patch)
treebf66fbc36f00585b254fb5a45b017e5e67743db3
parentReleasing debian version 2.5.15-1. (diff)
downloadidentify-4604e340e95ecd8d432e257f4594bb5a3752f9d5.tar.xz
identify-4604e340e95ecd8d432e257f4594bb5a3752f9d5.zip
Merging upstream version 2.5.17.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--identify/extensions.py4
-rw-r--r--setup.cfg2
-rw-r--r--tests/identify_test.py2
3 files changed, 7 insertions, 1 deletions
diff --git a/identify/extensions.py b/identify/extensions.py
index 0443e38..1c46e46 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -41,6 +41,7 @@ EXTENSIONS = {
'cxx': {'text', 'c++'},
'cylc': {'text', 'cylc'},
'dart': {'text', 'dart'},
+ 'dbc': {'text', 'dbc'},
'def': {'text', 'def'},
'dll': {'binary'},
'dtd': {'text', 'dtd'},
@@ -137,6 +138,7 @@ EXTENSIONS = {
'markdown': {'text', 'markdown'},
'md': {'text', 'markdown'},
'mdx': {'text', 'mdx'},
+ 'meson': {'text', 'meson'},
'mib': {'text', 'mib'},
'mjs': {'text', 'javascript'},
'mk': {'text', 'makefile'},
@@ -332,6 +334,8 @@ NAMES = {
'LICENSE': EXTENSIONS['txt'],
'MAINTAINERS': EXTENSIONS['txt'],
'Makefile': EXTENSIONS['mk'],
+ 'meson.build': EXTENSIONS['meson'],
+ 'meson_options.txt': EXTENSIONS['meson'],
'makefile': EXTENSIONS['mk'],
'NEWS': EXTENSIONS['txt'],
'NOTICE': EXTENSIONS['txt'],
diff --git a/setup.cfg b/setup.cfg
index 6d9ef3d..6893562 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 2.5.15
+version = 2.5.17
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown
diff --git a/tests/identify_test.py b/tests/identify_test.py
index d12334d..16b4f37 100644
--- a/tests/identify_test.py
+++ b/tests/identify_test.py
@@ -165,6 +165,8 @@ def test_tags_from_path_plist_text(tmpdir):
('Jenkinsfile', {'text', 'groovy', 'jenkins'}),
('build.jenkins', {'text', 'groovy', 'jenkins'}),
('build.jenkinsfile', {'text', 'groovy', 'jenkins'}),
+ ('meson.build', {'text', 'meson'}),
+ ('meson_options.txt', {'text', 'plain-text', 'meson'}),
# does not set binary / text
('f.plist', {'plist'}),