summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:04:52 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-03-11 08:04:52 +0000
commit508fc0b8207092855dd53ebbb42852ddfb92c6f7 (patch)
tree1884a67d422ea936a57693a10de3734f35c8348b
parentReleasing debian version 2.5.18-1. (diff)
downloadidentify-508fc0b8207092855dd53ebbb42852ddfb92c6f7.tar.xz
identify-508fc0b8207092855dd53ebbb42852ddfb92c6f7.zip
Merging upstream version 2.5.19.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--.pre-commit-config.yaml4
-rw-r--r--identify/extensions.py2
-rw-r--r--setup.cfg2
3 files changed, 5 insertions, 3 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index b29a10d..feb04ae 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -29,7 +29,7 @@ repos:
- id: pyupgrade
args: [--py37-plus]
- repo: https://github.com/pre-commit/mirrors-autopep8
- rev: v2.0.1
+ rev: v2.0.2
hooks:
- id: autopep8
- repo: https://github.com/PyCQA/flake8
@@ -38,6 +38,6 @@ repos:
- id: flake8
exclude: ^identify/vendor/licenses\.py$
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v0.991
+ rev: v1.0.1
hooks:
- id: mypy
diff --git a/identify/extensions.py b/identify/extensions.py
index 6addba6..dae7d2d 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -171,6 +171,7 @@ EXTENSIONS = {
'pm': {'text', 'perl'},
'png': {'binary', 'image', 'png'},
'po': {'text', 'pofile'},
+ 'pom': {'pom', 'text', 'xml'},
'pp': {'text', 'puppet'},
'prisma': {'text', 'prisma'},
'properties': {'text', 'java-properties'},
@@ -345,6 +346,7 @@ NAMES = {
'Pipfile.lock': EXTENSIONS['json'],
'PKGBUILD': {'text', 'bash', 'pkgbuild', 'alpm'},
'poetry.lock': EXTENSIONS['toml'],
+ 'pom.xml': EXTENSIONS['pom'],
'pylintrc': EXTENSIONS['ini'] | {'pylintrc'},
'README': EXTENSIONS['txt'],
'Rakefile': EXTENSIONS['rb'],
diff --git a/setup.cfg b/setup.cfg
index ae67a1f..600a1dc 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 2.5.18
+version = 2.5.19
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown