summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 02:36:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 02:36:20 +0000
commitd22d800c5589d6b466b8ddfc97c969eba9f7a017 (patch)
tree70cb948e9e48ddc0df308f4902b5a995beb1dd3f
parentUpdating to standards-version 4.7.0. (diff)
downloadidentify-d22d800c5589d6b466b8ddfc97c969eba9f7a017.tar.xz
identify-d22d800c5589d6b466b8ddfc97c969eba9f7a017.zip
Merging upstream version 2.5.36.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--.pre-commit-config.yaml8
-rw-r--r--identify/extensions.py2
-rw-r--r--setup.cfg2
3 files changed, 7 insertions, 5 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index bc35d55..6f61d88 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,6 +1,6 @@
repos:
- repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.5.0
+ rev: v4.6.0
hooks:
- id: trailing-whitespace
- id: end-of-file-fixer
@@ -23,12 +23,12 @@ repos:
hooks:
- id: add-trailing-comma
- repo: https://github.com/asottile/pyupgrade
- rev: v3.15.0
+ rev: v3.15.2
hooks:
- id: pyupgrade
args: [--py38-plus]
- repo: https://github.com/hhatto/autopep8
- rev: v2.0.4
+ rev: v2.1.0
hooks:
- id: autopep8
- repo: https://github.com/PyCQA/flake8
@@ -37,6 +37,6 @@ repos:
- id: flake8
exclude: ^identify/vendor/licenses\.py$
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v1.8.0
+ rev: v1.9.0
hooks:
- id: mypy
diff --git a/identify/extensions.py b/identify/extensions.py
index 12a3343..d427f67 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -341,6 +341,8 @@ NAMES = {
'.zshenv': EXTENSIONS['zsh'],
'AUTHORS': EXTENSIONS['txt'],
'BUILD': EXTENSIONS['bzl'],
+ 'Cargo.toml': EXTENSIONS['toml'] | {'cargo'},
+ 'Cargo.lock': EXTENSIONS['toml'] | {'cargo-lock'},
'CMakeLists.txt': EXTENSIONS['cmake'],
'CHANGELOG': EXTENSIONS['txt'],
'config.ru': EXTENSIONS['rb'],
diff --git a/setup.cfg b/setup.cfg
index 4e2ac59..9455e58 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 2.5.35
+version = 2.5.36
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown