summaryrefslogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-04 15:04:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-03-04 15:04:39 +0000
commit9143c0beda96a82579dc6ca87cba5ba74b907dea (patch)
tree79e9ef1de7f0919c55bcaad00f0d3b110b1ce371 /README.md
parentReleasing debian version 1.5.14-1. (diff)
downloadidentify-9143c0beda96a82579dc6ca87cba5ba74b907dea.tar.xz
identify-9143c0beda96a82579dc6ca87cba5ba74b907dea.zip
Merging upstream version 2.1.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'README.md')
-rw-r--r--README.md6
1 files changed, 3 insertions, 3 deletions
diff --git a/README.md b/README.md
index accf29b..788b7c4 100644
--- a/README.md
+++ b/README.md
@@ -37,7 +37,7 @@ If you have an actual file on disk, you can get the most information possible
When using a file on disk, the checks performed are:
-* File type (file, symlink, directory)
+* File type (file, symlink, directory, socket)
* Mode (is it executable?)
* File name (mostly based on extension)
* If executable, the shebang is read and the interpreter interpreted
@@ -76,11 +76,11 @@ optional arguments:
--filename-only
```
-```bash
+```console
$ identify-cli setup.py; echo $?
["file", "non-executable", "python", "text"]
0
-identify setup.py --filename-only; echo $?
+$ identify setup.py --filename-only; echo $?
["python", "text"]
0
$ identify-cli wat.wat; echo $?