summaryrefslogtreecommitdiffstats
path: root/identify
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-17 07:32:04 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-17 07:32:04 +0000
commitaf2b73458b2c6fd28d7da0516445502d28b2ba58 (patch)
treec95e921b503e6033fa83a00fbc0167efdacfc164 /identify
parentReleasing debian version 2.2.4-1. (diff)
downloadidentify-af2b73458b2c6fd28d7da0516445502d28b2ba58.tar.xz
identify-af2b73458b2c6fd28d7da0516445502d28b2ba58.zip
Merging upstream version 2.2.11.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'identify')
-rw-r--r--identify/extensions.py19
1 files changed, 15 insertions, 4 deletions
diff --git a/identify/extensions.py b/identify/extensions.py
index 0018da3..a6b2039 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -6,9 +6,11 @@ EXTENSIONS = {
'avif': {'binary', 'image', 'avif'},
'bash': {'text', 'shell', 'bash'},
'bat': {'text', 'batch'},
+ 'bats': {'text', 'shell', 'bash', 'bats'},
'bib': {'text', 'bib'},
'bmp': {'binary', 'image', 'bitmap'},
'bz2': {'binary', 'bzip2'},
+ 'bzl': {'text', 'bazel'},
'c': {'text', 'c'},
'cc': {'text', 'c++'},
'cfg': {'text'},
@@ -78,7 +80,8 @@ EXTENSIONS = {
'jade': {'text', 'jade'},
'jar': {'binary', 'zip', 'jar'},
'java': {'text', 'java'},
- 'jenkinsfile': {'text', 'groovy'},
+ 'jenkins': {'text', 'groovy', 'jenkins'},
+ 'jenkinsfile': {'text', 'groovy', 'jenkins'},
'jinja': {'text', 'jinja'},
'jinja2': {'text', 'jinja'},
'jpeg': {'binary', 'image', 'jpeg'},
@@ -180,11 +183,13 @@ EXTENSIONS = {
'tiff': {'binary', 'image', 'tiff'},
'toml': {'text', 'toml'},
'ts': {'text', 'ts'},
+ 'tsv': {'text', 'tsv'},
'tsx': {'text', 'tsx'},
'ttf': {'binary', 'ttf'},
'twig': {'text', 'twig'},
'txsprofile': {'text', 'ini', 'txsprofile'},
'txt': {'text', 'plain-text'},
+ 'urdf': {'text', 'xml', 'urdf'},
'v': {'text', 'verilog'},
'vb': {'text', 'vb'},
'vbproj': {'text', 'xml', 'vbproj'},
@@ -216,8 +221,10 @@ EXTENSIONS = {
'yang': {'text', 'yang'},
'yin': {'text', 'xml', 'yin'},
'yml': {'text', 'yaml'},
+ 'zcml': {'text', 'xml', 'zcml'},
'zig': {'text', 'zig'},
'zip': {'binary', 'zip'},
+ 'zpt': {'text', 'zpt'},
'zsh': {'text', 'shell', 'zsh'},
}
EXTENSIONS_NEED_BINARY_CHECK = {
@@ -261,8 +268,8 @@ NAMES = {
'.zshrc': EXTENSIONS['zsh'],
'.zshenv': EXTENSIONS['zsh'],
'AUTHORS': EXTENSIONS['txt'],
- 'BUILD': {'text', 'bazel'},
- 'BUILD.bazel': {'text', 'bazel'},
+ 'BUILD': EXTENSIONS['bzl'],
+ 'BUILD.bazel': EXTENSIONS['bzl'],
'CMakeLists.txt': EXTENSIONS['cmake'],
'CHANGELOG': EXTENSIONS['txt'],
'CONTRIBUTING': EXTENSIONS['txt'],
@@ -270,10 +277,12 @@ NAMES = {
'Dockerfile': {'text', 'dockerfile'},
'Gemfile': EXTENSIONS['rb'],
'Gemfile.lock': {'text'},
- 'Jenkinsfile': {'text', 'groovy'},
+ 'GNUmakefile': EXTENSIONS['mk'],
+ 'Jenkinsfile': EXTENSIONS['jenkins'],
'LICENSE': EXTENSIONS['txt'],
'MAINTAINERS': EXTENSIONS['txt'],
'Makefile': EXTENSIONS['mk'],
+ 'makefile': EXTENSIONS['mk'],
'NEWS': EXTENSIONS['txt'],
'NOTICE': EXTENSIONS['txt'],
'PATENTS': EXTENSIONS['txt'],
@@ -284,4 +293,6 @@ NAMES = {
'README': EXTENSIONS['txt'],
'Rakefile': EXTENSIONS['rb'],
'setup.cfg': EXTENSIONS['ini'],
+ 'WORKSPACE': EXTENSIONS['bzl'],
+ 'wscript': EXTENSIONS['py'],
}