summaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2023-12-10 09:56:10 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2023-12-10 09:56:10 +0000
commitecab5ee8d2dd5379a8d6fd24475a03eaaa8c0084 (patch)
treec93679ce4d0a665816db782c94262e2e5eb3be5d /tests
parentReleasing debian version 2.5.31-1. (diff)
downloadidentify-ecab5ee8d2dd5379a8d6fd24475a03eaaa8c0084.tar.xz
identify-ecab5ee8d2dd5379a8d6fd24475a03eaaa8c0084.zip
Merging upstream version 2.5.33.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'tests')
-rw-r--r--tests/identify_test.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/identify_test.py b/tests/identify_test.py
index ac458df..bb8aba5 100644
--- a/tests/identify_test.py
+++ b/tests/identify_test.py
@@ -151,6 +151,7 @@ def test_tags_from_path_plist_text(tmpdir):
@pytest.mark.parametrize(
('filename', 'expected'),
(
+ ('.salt-lint', {'text', 'salt-lint', 'yaml'}),
('test.py', {'text', 'python'}),
('test.mk', {'text', 'makefile'}),
('Makefile', {'text', 'makefile'}),
@@ -170,6 +171,7 @@ def test_tags_from_path_plist_text(tmpdir):
('build.jenkinsfile', {'text', 'groovy', 'jenkins'}),
('meson.build', {'text', 'meson'}),
('meson_options.txt', {'text', 'plain-text', 'meson'}),
+ ('Vagrantfile', {'text', 'ruby'}),
# does not set binary / text
('f.plist', {'plist'}),