summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.pre-commit-config.yaml8
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--identify/extensions.py2
-rw-r--r--setup.cfg2
5 files changed, 16 insertions, 6 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index bc35d55..6f61d88 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,6 +1,6 @@
repos:
- repo: https://github.com/pre-commit/pre-commit-hooks
- rev: v4.5.0
+ rev: v4.6.0
hooks:
- id: trailing-whitespace
- id: end-of-file-fixer
@@ -23,12 +23,12 @@ repos:
hooks:
- id: add-trailing-comma
- repo: https://github.com/asottile/pyupgrade
- rev: v3.15.0
+ rev: v3.15.2
hooks:
- id: pyupgrade
args: [--py38-plus]
- repo: https://github.com/hhatto/autopep8
- rev: v2.0.4
+ rev: v2.1.0
hooks:
- id: autopep8
- repo: https://github.com/PyCQA/flake8
@@ -37,6 +37,6 @@ repos:
- id: flake8
exclude: ^identify/vendor/licenses\.py$
- repo: https://github.com/pre-commit/mirrors-mypy
- rev: v1.8.0
+ rev: v1.9.0
hooks:
- id: mypy
diff --git a/debian/changelog b/debian/changelog
index 8facc2b..bffe6fa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+identify (2.5.36-1) sid; urgency=medium
+
+ * Uploading to sid.
+ * Updating to standards-version 4.7.0.
+ * Merging upstream version 2.5.36.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sat, 27 Apr 2024 04:36:36 +0200
+
identify (2.5.35-1) sid; urgency=medium
* Uploading to sid.
diff --git a/debian/control b/debian/control
index b7f9747..26fbad3 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends:
python3-all,
python3-setuptools,
Rules-Requires-Root: no
-Standards-Version: 4.6.2
+Standards-Version: 4.7.0
Homepage: https://github.com/chriskuehl/identify
Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/identify
Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/identify
diff --git a/identify/extensions.py b/identify/extensions.py
index 12a3343..d427f67 100644
--- a/identify/extensions.py
+++ b/identify/extensions.py
@@ -341,6 +341,8 @@ NAMES = {
'.zshenv': EXTENSIONS['zsh'],
'AUTHORS': EXTENSIONS['txt'],
'BUILD': EXTENSIONS['bzl'],
+ 'Cargo.toml': EXTENSIONS['toml'] | {'cargo'},
+ 'Cargo.lock': EXTENSIONS['toml'] | {'cargo-lock'},
'CMakeLists.txt': EXTENSIONS['cmake'],
'CHANGELOG': EXTENSIONS['txt'],
'config.ru': EXTENSIONS['rb'],
diff --git a/setup.cfg b/setup.cfg
index 4e2ac59..9455e58 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,6 @@
[metadata]
name = identify
-version = 2.5.35
+version = 2.5.36
description = File identification library for Python
long_description = file: README.md
long_description_content_type = text/markdown