summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-05-12 09:20:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-05-12 09:21:55 +0000
commit7ba4c2950137c4609521e2fbfb4d4496592e63ee (patch)
tree518c66295b27a1ed059185c1c2f57dcd9b873263
parentReleasing debian version 1.13.0-1. (diff)
downloadiredis-7ba4c2950137c4609521e2fbfb4d4496592e63ee.tar.xz
iredis-7ba4c2950137c4609521e2fbfb4d4496592e63ee.zip
Removing hacks for PEP517 support from before a pybuild plugin was available.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/README.source8
-rw-r--r--debian/control2
-rw-r--r--debian/local/setup.py37
-rwxr-xr-xdebian/rules9
4 files changed, 2 insertions, 54 deletions
diff --git a/debian/README.source b/debian/README.source
deleted file mode 100644
index 5391704..0000000
--- a/debian/README.source
+++ /dev/null
@@ -1,8 +0,0 @@
-iredis
-======
-
-setup.py used to build iredis has been generated with dephell (not in Debian yet, #962574):
-
- $ dephell deps convert --from pyproject.toml --to setup.py
-
- -- Daniel Baumann <daniel.baumann@progress-linux.org> Sun, 07 Feb 2021 08:10:31 +0100
diff --git a/debian/control b/debian/control
index 68ae671..b8d06e2 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,9 @@ Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
Build-Depends:
debhelper-compat (= 13),
dh-sequence-python3,
+ pybuild-plugin-pyproject,
python3,
+ python3-poetry,
python3-setuptools,
Rules-Requires-Root: no
Standards-Version: 4.6.2
diff --git a/debian/local/setup.py b/debian/local/setup.py
deleted file mode 100644
index 48c148e..0000000
--- a/debian/local/setup.py
+++ /dev/null
@@ -1,37 +0,0 @@
-# -*- coding: utf-8 -*-
-
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
-
-
-import os.path
-
-readme = ''
-here = os.path.abspath(os.path.dirname(__file__))
-readme_path = os.path.join(here, 'README.rst')
-if os.path.exists(readme_path):
- with open(readme_path, 'rb') as stream:
- readme = stream.read().decode('utf8')
-
-
-setup(
- long_description=readme,
- name='iredis',
- version='1.9.1',
- description='Terminal client for Redis with auto-completion and syntax highlighting.',
- python_requires='==3.*,>=3.6.0',
- project_urls={"homepage": "https://github.com/laixintao/iredis", "repository": "https://github.com/laixintao/iredis"},
- author='laixintao',
- author_email='laixintao1995@163.com',
- license='BSD-3-Clause',
- keywords='Redis key-value store Commandline tools Redis Client',
- classifiers=['Development Status :: 4 - Beta', 'Environment :: Console', 'Environment :: Console :: Curses', 'Environment :: MacOS X', 'Operating System :: OS Independent', 'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.7', 'Programming Language :: Python :: 3.8', 'Topic :: Database', 'License :: OSI Approved :: MIT License', 'Intended Audience :: Developers'],
- entry_points={"console_scripts": ["iredis = iredis.entry:main"]},
- packages=['iredis', 'iredis.data', 'iredis.data.commands'],
- package_dir={"": "."},
- package_data={"iredis.data": ["*.csv", "*.json"], "iredis.data.commands": ["*.md"]},
- install_requires=['click==7.*,>=7.0.0', 'configobj==5.*,>=5.0.0', 'importlib-resources==1.0.2', 'mistune==0.*,>=0.8.0', 'pendulum==2.*,>=2.0.0', 'prompt-toolkit==3.*,>=3.0.0', 'pygments==2.*,>=2.0.0', 'redis==3.*,>=3.0.0', 'wcwidth==0.1.9'],
- extras_require={"dev": ["pexpect==4.*,>=4.7.0", "pytest==5.*,>=5.0.0"]},
-)
diff --git a/debian/rules b/debian/rules
index b9f8430..238e44f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,15 +5,6 @@ export PYBUILD_NAME=iredis
%:
dh ${@} --buildsystem=pybuild
-execute_before_dh_auto_clean:
- cp debian/local/setup.py setup.py
-
-execute_after_dh_auto_clean:
- rm -f setup.py
-
-execute_before_dh_auto_configure:
- cp debian/local/setup.py setup.py
-
execute_after_dh_auto_install:
mkdir -p debian/iredis/usr/lib/python3/dist-packages/iredis/data
cp iredis/data/iredisrc debian/iredis/usr/lib/python3/dist-packages/iredis/data/iredisrc