summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2023-11-04 18:52:16 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2023-11-04 18:52:16 +0000
commit61a3777eb82896afbb2472017210c7642751ecc2 (patch)
treefbd20f88f28005e6083560ba65e0194403aa3e42 /pyproject.toml
parentReleasing debian version 1.13.1-1. (diff)
downloadiredis-61a3777eb82896afbb2472017210c7642751ecc2.tar.xz
iredis-61a3777eb82896afbb2472017210c7642751ecc2.zip
Merging upstream version 1.14.0.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index dc6f68d..088fb45 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "iredis"
-version = "1.13.1"
+version = "1.14.0"
description = "Terminal client for Redis with auto-completion and syntax highlighting."
authors = ["laixintao <laixintao1995@163.com>"]
readme = 'README.md'
@@ -19,6 +19,8 @@ classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ # "Programming Language :: Python :: 3.12",
"Topic :: Database",
"License :: OSI Approved :: MIT License",
"Intended Audience :: Developers",
@@ -26,22 +28,20 @@ classifiers = [
packages = [
{ include = "iredis" },
- { include = "tests", format = "sdist" },
]
[tool.poetry.dependencies]
python = "^3.7"
prompt_toolkit = "^3"
Pygments = "^2"
-mistune = "^2.0"
+mistune = "^3.0"
configobj = "^5.0"
-click = "^7.0"
-pendulum = "^2.0"
-importlib-resources = "^5.1.0"
+click = "^8.0"
+pendulum = "^2.1.0"
# wcwidth 0.2.x uses pkg_resources which is not supported by PyOxidizer
wcwidth = "0.1.9"
-packaging = "^21.3"
-redis = "^4.3.4"
+packaging = "^23.0"
+redis = "^5.0.0"
[tool.poetry.dev-dependencies]
pytest = "^7.2"