summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-28 18:30:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-28 18:30:31 +0000
commitec8301570add3f8582e96d7f9aaed87e14154cca (patch)
treed71bf3f64b9d2342e5b7513e1ac5781e323972f6 /pyproject.toml
parentReleasing debian version 1.9.4-2. (diff)
downloadiredis-ec8301570add3f8582e96d7f9aaed87e14154cca.tar.xz
iredis-ec8301570add3f8582e96d7f9aaed87e14154cca.zip
Merging upstream version 1.10.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 4 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index aba1fba..f722d8b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "iredis"
-version = "1.9.4"
+version = "1.10.0"
description = "Terminal client for Redis with auto-completion and syntax highlighting."
authors = ["laixintao <laixintao1995@163.com>"]
readme = 'README.md'
@@ -19,6 +19,7 @@ classifiers = [
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Topic :: Database",
"License :: OSI Approved :: MIT License",
"Intended Audience :: Developers",
@@ -31,7 +32,7 @@ packages = [
[tool.poetry.dependencies]
python = "^3.6"
-redis = "^3"
+redis = "^3.4.0"
prompt_toolkit = "^3"
Pygments = "^2"
mistune = "^0.8"
@@ -43,7 +44,7 @@ importlib-resources = "^5.1.0"
wcwidth = "0.1.9"
[tool.poetry.dev-dependencies]
-pytest = "^5"
+pytest = "^6"
pexpect = "^4.7"
[tool.poetry.scripts]