summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 87bb464..c9a676a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "iredis"
-version = "1.12.1"
+version = "1.13.0"
description = "Terminal client for Redis with auto-completion and syntax highlighting."
authors = ["laixintao <laixintao1995@163.com>"]
readme = 'README.md'
@@ -15,7 +15,6 @@ classifiers = [
"Environment :: Console :: Curses",
"Environment :: MacOS X",
"Operating System :: OS Independent",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
@@ -31,8 +30,7 @@ packages = [
]
[tool.poetry.dependencies]
-python = "^3.6"
-redis = "^3.4.0"
+python = "^3.7"
prompt_toolkit = "^3"
Pygments = "^2"
mistune = "^2.0"
@@ -43,9 +41,10 @@ importlib-resources = "^5.1.0"
# wcwidth 0.2.x uses pkg_resources which is not supported by PyOxidizer
wcwidth = "0.1.9"
packaging = "^21.3"
+redis = "^4.3.4"
[tool.poetry.dev-dependencies]
-pytest = "^6"
+pytest = "^7.2"
pexpect = "^4.7"
[tool.poetry.scripts]