summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-21 07:51:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-21 07:51:15 +0000
commitd8409535af8f9e9944c63c73f33bc7cc9577ccfb (patch)
tree5d3adfdc0309ee50bd74d974d3488ea6ba5b8229 /Makefile
parentInitial commit. (diff)
downloadjinjax-d8409535af8f9e9944c63c73f33bc7cc9577ccfb.tar.xz
jinjax-d8409535af8f9e9944c63c73f33bc7cc9577ccfb.zip
Adding upstream version 0.45+dfsg.upstream/0.45+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..139a760
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,37 @@
+.PHONY: test
+test:
+ poetry run pytest -x src/jinjax tests
+
+.PHONY: lint
+lint:
+ poetry run ruff check src/jinjax tests
+
+.PHONY: coverage
+coverage:
+ poetry run pytest --cov-config=pyproject.toml --cov-report html --cov jinjax src/jinjax tests
+
+.PHONY: types
+types:
+ poetry run pyright src/jinjax
+
+.PHONY: install
+install:
+ poetry install --with dev,test
+ poetry run pre-commit install
+
+.PHONY: install.docs
+install.docs:
+ pip install -e ../jinjax-ui/
+ pip install -e ../claydocs/
+
+.PHONY: docs
+docs:
+ cd docs && python docs.py
+
+.PHONY: docs.build
+docs.build:
+ cd docs && python docs.py build
+
+.PHONY: docs.deploy
+docs.deploy:
+ cd docs && ./deploy.sh