summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e5836e6..d38a070 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -34,7 +34,10 @@ classifiers = [
python = "^3.10"
jinja2 = ">=3.0"
markupsafe = ">=2.0"
-whitenoise = ">=5.3"
+whitenoise = { version = ">=5.3", optional = true }
+
+[tool.poetry.extras]
+whitenoise = ["whitenoise"]
[tool.poetry.group.dev]
optional = true
@@ -52,7 +55,7 @@ optional = true
pytest = "^8.1.1"
pytest-cov = "*"
ruff = ">0.3"
-
+whitenoise = ">=5.3"
[tool.coverage.run]
branch = true