summaryrefslogtreecommitdiffstats
path: root/doc/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-30 22:36:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-30 22:36:10 +0000
commit61d0a8bdffbbb7229776d2f4f2e79ed22d21551f (patch)
tree2e249969fedce45eb37ae6314ad167595900fe38 /doc/meson.build
parentReleasing debian version 1.4-4. (diff)
downloadlibnvme-61d0a8bdffbbb7229776d2f4f2e79ed22d21551f.tar.xz
libnvme-61d0a8bdffbbb7229776d2f4f2e79ed22d21551f.zip
Merging upstream version 1.5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build13
1 files changed, 8 insertions, 5 deletions
diff --git a/doc/meson.build b/doc/meson.build
index edbc3be..f12f3b9 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -9,14 +9,15 @@
#
api_files = [
+ 'fabrics.h',
'filters.h',
'ioctl.h',
'linux.h',
'log.h',
'mi.h',
+ 'nbft.h',
'tree.h',
'types.h',
- 'fabrics.h',
'util.h'
]
@@ -44,10 +45,12 @@ endforeach
subdir('rst')
+top_source_dir = meson.current_source_dir() + '/../'
+
want_docs = get_option('docs')
want_docs_build = get_option('docs-build')
-kernel_doc = find_program('kernel-doc')
-kernel_doc_check = find_program('kernel-doc-check')
+kernel_doc = find_program(top_source_dir + 'scripts/kernel-doc')
+kernel_doc_check = find_program(top_source_dir +'scripts/kernel-doc-check')
test('kdoc', kernel_doc_check, args: api_paths)
@@ -55,7 +58,7 @@ if want_docs != 'false'
if want_docs == 'all' or want_docs == 'man'
mandir = join_paths(get_option('mandir'), 'man2')
- list_man_pages = find_program('list-man-pages.sh')
+ list_man_pages = find_program(top_source_dir + 'scripts/list-man-pages.sh')
if want_docs_build
foreach apif : api_paths
c = run_command(list_man_pages, apif, check: true)
@@ -78,7 +81,7 @@ if want_docs != 'false'
endforeach
else
if want_docs == 'all' or want_docs == 'man'
- list_pre_compiled = find_program('list-pre-compiled.sh')
+ list_pre_compiled = find_program(top_source_dir + 'scripts/list-pre-compiled.sh')
m = run_command(list_pre_compiled, check: true)
man_pages = m.stdout().strip().split('\n')
install_data(man_pages, install_dir: mandir)